Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сравнение суммы по номеру док
 
Добрый день!

Есть 2 таблицы (моя и бух), у нас с ней не сходятся данные, сидел вручную крыжил видать что-то пропустил. Можно ли как то сопоставить из 2-х таблиц номера док с суммами, чтобы смогли увидеть где идут расхождения или чего нет!
Пример приложил. Спасибо!
 
Если уберете лишние пробелы в номере документа в правой таблице, то можно подтянуть нужные суммы функцией ВПР. См.файл
Согласие есть продукт при полном непротивлении сторон.
 
ого... блин огромное Вам человеческое Спасибо!))) Пробелы уберем!
 
Цитата
IntelXeon написал:
Можно ли как то сопоставить
можно, но для этого нужно привести данные к одинаковому виду. Например в правой таблице убрать лишние пробелы.
УФ поможет увидеть разные, а вот по чему придется смотреть самому.
 
Цитата
IntelXeon написал: ого... блин
Магия, однако :)
Изучите справку по функции ВПР - очень мощный инструмент!
Согласие есть продукт при полном непротивлении сторон.
 
Sanja, судя по таблице нужно тянуть по двум параметрам (номер документа и контрагент) Впр без доп. столбца не справится. ;)
 
Цитата
IntelXeon написал: сопоставить из 2-х таблиц номера док с суммами
Я исходил из этого
Согласие есть продукт при полном непротивлении сторон.
 
если уберете пробелы то формула массива, по двум параметрам, подтянет цену.
Код
=ИНДЕКС($K$2:$K$6;ПОИСКПОЗ(A2&B2;$H$2:$H$6&$I$2:$I$6;))
 
Благодарю!

P.S К сожелению, не все оказалось радужно, пробелы убрал через заменить, но почти везде пишет Н/Д (видать он как-то по др сортирует)

V, что-то не получилось по вашему методу!  
Изменено: IntelXeon - 11 Июл 2019 11:57:44
 
Цитата
IntelXeon написал: но почти везде пишет Н/Д
Значит не находит в правой таблице ячейку с таким номером. Например в проверочной таблице нет номера 412/2 поэтому #Н/Д
Изменено: Sanja - 11 Июл 2019 12:17:41
Согласие есть продукт при полном непротивлении сторон.
 
Цитата
Sanja написал:
Значит не находит в правой таблице ячейку с таким номером. Например в проверочной таблице нет номера 412/2 поэтому #Н/Д

Прикрепленные файлы
Пример (2).xlsx  (11.38 КБ)

Изменено: Sanja  - 11 Июл 2019 12:17:41
Вот дополнил пример реальный! (может конечно я что-то туплю =)  )
Изменено: IntelXeon - 11 Июл 2019 14:19:16
 
в N14
Код
=ВПР(C14;$K$14:$M$23;3;0)

если Н/Д значит нет такого.
П.С. бездумно цитировать не стоит.
Изменено: V - 11 Июл 2019 13:16:35
 
я добавил пример, там есть этот номер документа! Пример - 412/2, а выдает Н/Д или он работает по какому-то др алгоритму?! (сорри за тупняк)
 
Обратите внимание
=ВПР(A2;$H$2:$K$6;4;0)
Согласие есть продукт при полном непротивлении сторон.
 
Цитата
Sanja написал:
Обратите внимание=ВПР(A2;$H$2:$K$6;4;0)
не совсем понял что вы имелли ввиду, но как я понял что по этой формуле
Код
=ВПР(RC[-4];R2C8:R6C11;4;0)
она смотри по строке и соответственно снижает на одну позицию вниз! А нельзя как то сделть чтобы она не уезжала вниз... тогда наверно он бы заполнил эти строки и соответственно остались бы #Н/Д только те которых нет в др табл.!


 
Уберите галку с пункта Стиль ссылок R1C1 и посмотрите на мою формулу и свою
Для ссылки на таблицу в ВПР нужно использовать АБСОЛЮТНЫЕ ссылки
Согласие есть продукт при полном непротивлении сторон.
 
значение в ячейке а2 = "412/1"
Значение в Н2 = "412/1      "

Как Вы думаете, они равны?
 
Цитата
Sanja написал:
Уберите галку с пункта Стиль ссылок R1C1 и посмотрите на мою формулу и своюДля ссылки на таблицу в ВПР нужно использовать АБСОЛЮТНЫЕ ссылки
ааа вон оно как оказывается ппц... как много я не знаю про Excel - все получилось Спасибо!
Страницы: 1
Читают тему (гостей: 1)
Наверх