Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Посчитать количество баллов для каждой школы
 
Надо посчитать баллы как это правильно сделать? Подскажите может форму таблицы поменять?
 
ПРоверяйте
Кол-во баллов наверное так нужно считать:
=СУММПРОИЗВ(X11:Z11;{3;2;1})
Изменено: Максим В. - 12 Июл 2019 14:30:28
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Спасибо.
Изменено: anvar05 - 12 Июл 2019 14:41:19
 
anvar05, добавил формулу в сообщении №3
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Как вы это делаете если не секрет. Я могу этому научиться?
 
anvar05, конечно сможете. Было бы желание. Начните с раздела Приёмы
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Максим В.,А как мне ваши формулы перенести на другую таблицу. И еще в конце таблицы которую вы прислали ошибка у школы девять там нет 3 места.
Изменено: anvar05 - 12 Июл 2019 15:06:21
 
Просто скопировать и вставить. При необходимости подправить диапазоны.
Единственный момент, эта формула:
=СУММ(ДЛСТР(C11:W11)-ДЛСТР(ПОДСТАВИТЬ(C11:W11;СТОЛБЕЦ(A11);"")))
формула массива. Требует ввода сочетанием клавиш Ctrl+Shift+Enter/
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Максим В.,Вы можете мне расшифровать эту формулу =СУММ(ДЛСТР(C11:W11)-ДЛСТР(ПОДСТАВИТЬ(C11:W11;СТОЛБЕЦ(A11);""))) как он находит и суммирует только 1 или 2 или 3 из ячейки
Изменено: anvar05 - 12 Июл 2019 16:46:52
 
ДЛСТР(C11:W11) возвращает длины текста содержащегося в ячейках массива
ДЛСТР(ПОДСТАВИТЬ(C11:W11;СТОЛБЕЦ(A11);"")) делает тоже самое, но без учета 1,2 или 3 (за это отвечает функция ПОДСТАВИТЬ()
Находим разницу длин и суммируем. Это и будет количество соответсвующих оценок.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Максим В.,А как понять из этой формулы ДЛСТР(ПОДСТАВИТЬ(C11:W11;СТОЛБЕЦ(A11);"")) что он не учитывает 1?
А если эту формулу =СУММ(ДЛСТР(C11:W11)-ДЛСТР(ПОДСТАВИТЬ(C11:W11;СТОЛБЕЦ(A11);""))) написать так =СУММ(ДЛСТР(C11:W11)-ДЛСТР(ПОДСТАВИТЬ(C11:W11;"1";"")))
Изменено: anvar05 - 12 Июл 2019 22:08:34
 
Цитата
anvar05 написал:
как понять из этой формулы ... что он не учитывает 1?
СТОЛБЕЦ(A11) вернет 1. При протягивании формулы вправо 2 и 3.
Цитата
anvar05 написал:
А если эту формулу ... написать так
Можно и так. Но при протягивании придется менять 1 на 2 и на 3.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1
Читают тему (гостей: 2)
Наверх