Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование данных с большим количеством строк
 
Добрый день, уважаемые форумчане!
Необходима Ваша помощь в сборе данных.
Необходимо собрать данные с Табеля на определенного сотрудника, за определенную неделю по определенным условиям. Например: сколько часов отработал Иванов на неделе 20 по условию
Кол-во   отработанных часов
Данные необходимо собирать с Табеля в диапазоне F1:AJ21. Считать в ячейке F25 и далее.
Левее, есть существующая формула массива, но т.к. данных очень много, а именно 365 столбцов и 2000 строк, то Excel отказывается отрабатывать массив. Выдает ошибку: "Недостаточно ресурсов....",  зависает минут на 10, так ничего и не подсчитав.
Может быть есть идеи более "легкой" функции сбора данных.
Заранее благодарна!
Файл прикреплен.
 
Добрый и Вам. Попробуйте такую формулу:
=СУММПРОИЗВ($F$6:$AJ$21;--(($B$6:$B$21=$B25)*($E$6:$E$21="отраб время")*($F$1:$AJ$1=D$24)))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Zhura777 идеально было бы трансформировать таблицу в плоскую и потом по ней получить сводную.
 
Код
=СУММ(ИНДЕКС(1:21;ПОИСКПОЗ($B25;$B:$B;);ПОИСКПОЗ(E$24;$1:$1;)):ИНДЕКС(1:21;ПОИСКПОЗ($B25;$B:$B;);ПОИСКПОЗ(E$24+1;$1:$1;)-1))
формула длинная, но вычисления - элементарные
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Спасибо ВАМ!!!
 
Максим В., спасибо!
 
Цитата
Максим В. написал:
СУММПРОИЗВ($F$6:$AJ$21;--(($B$6:$B$21=$B25)*($E$6:$E$21="отраб время")*($F$1:$AJ$1=D$24)))
Добрый день!
Подскажите, а как в это же вычисление добавить еще один параметр: сумму по "перераб-ки ночь". У меня постоянно выдает #ЗНАЧ.
 
Цитата
Ігор Гончаренко написал:
Код ? 1=СУММ(ИНДЕКС(1:21;ПОИСКПОЗ($B25;$B:$B;);ПОИСКПОЗ(E$24;$1:$1;)):ИНДЕКС(1:21;ПОИСКПОЗ($B25;$B:$B;);ПОИСКПОЗ(E$24+1;$1:$1;)-1))формула длинная, но вычисления - элементарные
Подскажите, а как в это же вычисление добавить еще один параметр: сумму по "перераб-ки ночь". У меня постоянно выдает #ЗНАЧ.
 
Zhura777, а ведь  одно было не сносить сообщения,  не вставлять полные цитаты,  а в одном сообщении обратиться к двум: как в ваших формулах...
 
Добрый день!
Задача по сумме немного усложнилась.
Необходимо суммировать данные с Листа 2 по нескольким параметрам: ном.недели, ФИО, отраб время, перераб-ки, перераб-ки ночь. Данные нужны на листе 1 в желтые столбцы. Суммирование через суммеслимн выдает ошибку #ЗНАЧ.
Помогите, пжт.

Спасибо!
Страницы: 1
Читают тему (гостей: 1)
Наверх