Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сумма если пусто, брать из другой ячейки
 
Подскажите, пожалуйста, как посчитать сумму некоего столбца значений, при условии, если в ячейке пусто, то брать из другой. Пробую так, но считает только 1-ю и 5-ю ячейку, а мне нужен диапазон. Спасибо.

=СУММ(ЕСЛИ(ЕПУСТО(B1);A1;B1):ЕСЛИ(ЕПУСТО(B5);A5;B5))

A     B
1     10
2     20
3
4     40
5     50

В ячейке B6 должна быть сумма, рассчитанная так: 10 + 20 + 3 + 40 + 50 = 123.
Изменено: Ivan2Excel - 17 Июл 2019 16:47:43
 
После изменения первого поста правильно у skais675,
Лень двигатель прогресса, доказано!!!
 
Сергей, skais675, Правильно будет тогда когда ТС сменит ник.  :D
 
Ivan2Excel, проверьте личку.
До устранения замечания помощь скрыта.
Страницы: 1
Читают тему (гостей: 1)
Наверх