Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Прибавить к предыдущим значениям 1, Прибавить к предыдущим значениям в столбце 1 и вывести
 
Здравствуйте. Ребят подскажите формулу пожалуйста. Имеется несколько строк (будет 3 или 4 строки) в столбце вида:
9695
9897
10226
11475
Нужно прибавить к этим числам 1 и продолжить далее чтобы на выходе было:
9696
9898
10227
11476
9697
9899
10228
11477
9698
9900
10229
11478 и т.д.
Числа не должны повторяться!
Как логичней всё это реализовать, подскажите.
 
В ячейку А6 пишите формулу =A2+1 и протягиваете вниз
 
Как вариант:
=ИНДЕКС($A$2:$A$5;ОСТАТ(СТРОКА(B1)-1;4)+1)+ЦЕЛОЕ((СТРОКА(B1)-1)/4)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Я не понял, нужно, чтобы не повторялись значения или прибавить единицу. Хотя если просто прибавить единицу то значения не будут повторять около 200 раз.
 
msi2102, А вот с этим да, т.к. между числами разный интервал, а между первым и вторым числом наименьший интервал 202 значения, а дальше по формуле идут повторы.
Вот самый интерес, можно ли реализовать без повторов, чтобы отсчет шел от наибольшего числа перед тем как пойдут повторы?
 
Повторы - это уже другая тема.

По вопросу темы.
Вписать в любую ячейку 1, копировать ячейку, выделить диапазон для изменения, Спецвставка-Сложить-ОК
 
Для того, чтобы отвечать на Ваши вопросы, нужно, знать для чего Вам это, откуда взялись первые 4 значения, какие границы у числового ряда и т.д. Вы задали вопрос как прибавить 1 к значениям на который Вам ответили. Если у Вас какая-то другая цель, то есть не просто прибавить 1, то сформулируйте вопрос иначе, что бы была понятна суть вашей проблемы.
 
Цитата
msi2102 написал: сформулируйте вопрос иначе...
... в новой теме
 
vikttur, да я не против, просто попытался объяснить darkside134, что формулировать вопрос надо правильно.
Страницы: 1
Читают тему (гостей: 1)
Наверх