Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формула для выбора значения ячейки по двум совпадающим условиям
 
Здравствуйте! Прошу помощи в составлении формулы, которая проверит совпадение по двум условиям и подставит нужное значение. В примере книги есть два листа. На первом таблица с фамилиями, датами и ячейками времени, которые нужно заполнить данными со второго листа, где список с фамилиями, датами и временем. Нужно, чтобы формула на первом листе в ячейках B4-E6 сравнивала фамилию со вторым листом, потом дату и если фамилия и дата совпадает, то подставляла соответствующее значение из ячейки С2-С13 второго листа. Пробовал сделать через ИНДЕКС и ПОИСКПОЗ, но ищет только до первого совпадения первого условия, не хватает знаний.
 
Код
=ИНДЕКС(Лист2!$C$2:$C$13;ПОИСКПОЗ($A4&B$2;Лист2!$A$2:$A$13&Лист2!$B$2:$B$13;0))

Формула массива. Вводим нажатием CTRL+SHIFT+ENTER
 
Формула с массивным вводом
Код
=INDEX(Лист2!$C$2:$C$13;MATCH(1;(B$2=Лист2!$B$2:$B$13)*(Лист1!$A4=Лист2!$A$2:$A$13);0))
Изменено: jakim - 21 Июл 2019 19:00:29
 
Также может быть и обычная формула
Код
=LOOKUP(2;1/(B$2=Лист2!$B$2:$B$13)/($A4=Лист2!$A$2:$A$13);Лист2!$C$2:$C$13)
 
Спасибо! Все варианты рабочие.
Цитата
jakim написал:
Также может быть и обычная формула
Скажите, что означают 2;1 после lookup в Вашей формуле?
 
Если даты идут по порядку в обоих листах и фамилии сгруппированы, то можно обойтись такой формулой:
=ИНДЕКС(Лист2!$C$2:$C$13;(СТРОКА(B1)-1)*4+СТОЛБЕЦ(A4))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
Roinmana написал:
Скажите, что означают 2;1 после lookup в Вашей формуле?
Посмотрите эту статью: Поиск последнего значения в строке или столбце функцией ПРОСМОТР
Страницы: 1
Читают тему (гостей: 1)
Наверх