Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Определение позиции в выбранном диапазоне по точному совпадению названия
 
Добрый вечер. Подскажите, пожалуйста, есть ли такая формула в экселе, аналогичная "суммесли", которая может подставить текст из ячейки напротив, согласно заданному значению. Если в "суммесли" формула суммирует все  цифры при заданном значение, то необходимо формула, где бы подставлялась значение в выбранном диапазоне.
Есть список сотрудников с ФИО и должностями. Есть список этих же сотрудников с окладами. Необходимо два списка соединить вместе. Но нельзя их упорядочивать по алфавиту, ибо один список с окладами слишком широк, надо перенести должности формулой.
 
ВПР или ИНДЕКС и ПОИСКПОЗ
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Виктория2012, такая формула есть.
А если ещё и файл прикрепите, то с очень большой долей вероятности вам помогут ее написать.

Представьте на минуту, что вы умеете завязывать какой-либо сложный узел, и тут, к вам подходит человек и просит: "Расскажи пожалуйста, как завязать этот узел". Думаю, что без веревки, на которой бы вы показали - вам это будет очень трудно сделать. Вот так же и с файлом примером)
Нужно бежать со всех ног, чтобы только оставаться на месте, а чтобы куда-то попасть, надо бежать как минимум вдвое быстрее!
 
ВПР практически подошло, но что-то пошло не так
 
Виктория2012, 0 в последний параметр добавьте
=ВПР(H2;$A$2:$B$8;2;0)
Изменено: Stics - 25 Июл 2019 14:31:00
 
=ВПР(H2;$A$2:$B$8;2;ЛОЖЬ)
 
Получается. Спасибо
Объясните, пожалуйста, смысл того, что сначала надо поставить 2, а потом 0 или ЛОЖЬ
Изменено: Виктория2012 - 26 Июл 2019 12:48:33
 
Вот вам еще вариант:
Код
=ИНДЕКС($B$2:$B$8;ПОИСКПОЗ(H8;$A$2:$A$8;0))

По Вашему вопросу:
Цитата
Виктория2012 написал: сначала надо поставить 2, а потом 0 или ЛОЖЬ
2 - указывает на то из какого столбца таблицы необходимо подставлять данные в том случае, если совпадения найдены. Так как вы хотите выводить должность, а она находится во втором столбце поисковой таблицы, то и указывать нужно  2.
0 или ложь - сообщают формуле о том, что поиск необходимо вести по точному совпадению.
Есть еще вариант вместо 0 поставить 1 - в этом случае поиск будет производиться по приблизительному совпадению, но это стоит делать только в том случае, если поиск вы производите по цифрам. С текстом лучше всегда указывать 0.
Нужно бежать со всех ног, чтобы только оставаться на месте, а чтобы куда-то попасть, надо бежать как минимум вдвое быстрее!
 
Спасибо.
Страницы: 1
Читают тему (гостей: 1)
Наверх