Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Контроль дублей в двух столбцах
 
Добрый день. Возможно мой вопрос банален, прошу заранее меня простить, не нашел решения.

Есть 2 столбца.
Столбец А - это имя представителя;
Столбец B - это email, с которого уже связывались с данным представителем.
Задача человека  постоянно заполнять ячейки А( указывая новых и старых представителей), при этом использовав уникальный email ( введя его в ячейку B), но в некоторых случаях дубли не являются ошибкой.

Каким образом можно осуществить постоянный контроль дублей?
Чтобы введя старого представителя, указав по неосторожности уже использованный имейл, было понятно, что необходим другой имейл. Спасибо
Изменено: Davidrom - 16 Авг 2019 10:50:55
 
Цитата
Dav1dr0m написал:
Каким образом
формула, макрос, условное форматирование...
файл ваш где?
 
Цитата
Dav1dr0m: Дубли в двух столбцах
и? Что сделать-то…?
Цитата
Dav1dr0m: …заполнять…использовав уникальный email…в некоторых случаях дубли не являются ошибкой
суперская постановка задачи  :D что это за некоторые случаи?)))
Короче, с вас более точное название темы и файл-пример  ;)

P.S.: не обратил внимания на ник — замените цифры на буквы
Изменено: Jack Famous - 16 Авг 2019 09:03:48
Реквизиты для благодарностей — в профиле
 
Выделяем столбец B (где email) и далее Главная - Условное форматирование - Правила выделение ячеек - повторяющиеся значения
 
Цитата
Jack Famous написал:
суперская постановка задачи   что это за некоторые случаи?)))
Добавил файл. Заполнил еще несколько столбцов, что означает, что в таблице много посторонних данных. Таблица заполняется постоянно.

Задача простая - есть постоянные значения Имен, и на них отправляются письма с разных email.
С одного email может быть отправлено на 1 Имя максимум 3-5 писем.  Т.е дубль ошибкой не является.  Там будут меняться другие показатели, например дата.

В итоге у нас заполнено по 100 строк Имен ( где постоянно повторяются значения, тк к одинм и тем же именам обращались много раз с разных email) и 100 строк email (где значения также повторяются, но для разных ИМЕН(кроме случаев когда с 1 имейл неск раз обращались к 1 имя))

Т.е есть связка ИМЯ1 - ИМЕЙЛ1. Возможен ли подсчет таких связок? Чтобы при случайном добавлении ИМЯ1- ИМЕЙЛ1 мы понимали что такая связка уже использовалась?
 
 
Цитата
Davidrom: есть связка ИМЯ1 - ИМЕЙЛ1. Возможен ли подсчет таких связок?
пфффф ну есессна))))
1. в доп. столбец формулу =ячейка с именем &"-"& ячейка с мылом (это сцепка)
2. считаем сцепки через =СЧЁТЕСЛИ(), ну или УФ, как Mukhtar советует, если количество не важно и нужно просто дубли выделить
Изменено: Jack Famous - 16 Авг 2019 11:15:10
Реквизиты для благодарностей — в профиле
 
Dav1dr0m посмотри, выделяется красным цветом повторяющий Имя1-Имейл1
Изменено: Mukhtar - 16 Авг 2019 11:19:19
 
УФ не подходит так как в осн таблице не будет дополнительного столбца для отображения связок. Добавил в отдельную таблицу подсчет связок, но тк есть пустые значения он ставит 65511.

Как сделать чтобы в пустых ячейках не было 65511 при этом учитывались пустые  ( т.к данные будут заполняться же дальше)?

Тогда  просто суммирование кол-ва дублей и одну цифру вставлю в осн таблицу, при создании дубля она будет меняться, но я буду знать какое кол-во дублей допустимое.  
 
Цитата
Davidrom написал:
УФ не подходит так как в осн таблице не будет дополнительного столбца для отображения связок
а что мешает прямо в УФ запилить формулу?
=СУММПРОИЗВ(($A$2:$A$13=$A2)*($C$2:$C$13=$C2))>$J$1
Каждому For свой Next
 
Блестяще! Огромная благодарность!  
Страницы: 1
Читают тему (гостей: 1)
Наверх