Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Отбор значений в сводную по двум параметрам с разных листов
 
Всем добрый день!
Помогите, пожалуйста, с решением:
В сводную пытаюсь вставить формулу для отбора данных с листов
Формула не работает...
 
mbd124, а можете конкретно описать что нужно сделать ?
 
нужно выбирать с каждого листа одинаковые размеры и рост и суммировать в сводной
 
mbd124, а почему просто не просуммировать ячейки если таблицы одинаковые?!

http://excelexpert.ru/kak-summirovat-dannye-s-raznyx-listov-knig-excel
Код
=СУММ('подразделение х:подразделение Z'!B4)
Изменено: Mershik - 20 Авг 2019 11:20:00
 
Консолидация (объединение) данных из нескольких таблиц в одну
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Листов немало, поэтому хочется автоматизировать задачу
 
До кучи: Как просуммировать данные с нескольких листов, в том числе по условию
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
"......Но, если необходимо будет просуммировать данные по отдельным товарам со всех листов, а товар расположен в хаотичном порядке, разном для каждого листа и количество строк различается, то здесь такая формула не подойдет. Можно воспользоваться формулой массива, которая несколько неудобна именно в таком виде:
Код
=СУММПРОИЗВ(СУММЕСЛИ(ДВССЫЛ({"Январь":"Февраль":"Март":"Апрель":"Май":"Июнь"}&"!B3:B100");B2;ДВССЫЛ({"Январь":"Февраль":"Март":"Апрель":"Май":"Июнь"}&"!C3:C100")))

Именно эту формулу я пытаюсь использовать по той простой причине, что таблицы неодинаковые
 
Так Вы бы за аргументами тогда следили. Почему с листа итогового Вы в качестве критерия берете А4, когда критерии в столбце В? Так все будет считать:
Код
=СУММПРОИЗВ(СУММЕСЛИ(ДВССЫЛ("'"&{"подразделение Х":"подразделение Y":"подразделение Z"}&"'!A$4:A$6");$B4;ДВССЫЛ("'"&{"подразделение Х":"подразделение Y":"подразделение Z"}&"'!B$4:B$6")))
просто заменил А4 на В4.
А вот так формула будет универсальной и можно будет записать 1 раз в С4 и протянуть на остальные ячейки итоговой таблицы:
Код
=СУММПРОИЗВ(СУММЕСЛИ(ДВССЫЛ("'"&{"подразделение Х":"подразделение Y":"подразделение Z"}&"'!A$4:A$6");$B4;ДВССЫЛ("'"&{"подразделение Х":"подразделение Y":"подразделение Z"}&"'!"&АДРЕС(4;СТОЛБЕЦ(B1))&":"&АДРЕС(6;СТОЛБЕЦ(B1)))))
Изменено: Дмитрий(The_Prist) Щербаков - 20 Авг 2019 11:52:31
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Вариант на Power Query:
Код
let
    Source = Excel.Workbook(File.Contents(Excel.CurrentWorkbook(){[Name="Адрес"]}[Content]{0}[Column1]), null, true),
    FilteredRows = Table.SelectRows(Source, each ([Kind] = "Sheet") and ([Item] <> "ИТОГ")),
    RemovedOtherColumns = Table.SelectColumns(FilteredRows,{"Name", "Data"}),
    AddedCustom = Table.AddColumn(RemovedOtherColumns, "Таблицы", each Table.PromoteHeaders( Table.SelectRows([Data], each ([Column1] <> null)), [PromoteAllScalars=true] )),
    Custom1 = Table.Combine( AddedCustom[Таблицы] ),
    ReplacedValue = Table.ReplaceValue(Custom1,null,0,Replacer.ReplaceValue,{"2", "3", "4", "5", "6", "7"}),
    UnpivotedOtherColumns = Table.UnpivotOtherColumns(ReplacedValue, {"размер"}, "Рост", "Значение"),
    ReplacedValue1 = Table.ReplaceValue(UnpivotedOtherColumns,0,null,Replacer.ReplaceValue,{"Значение"}),
    PivotedColumn = Table.Pivot(ReplacedValue1, List.Distinct(ReplacedValue1[Рост]), "Рост", "Значение", List.Sum)
in
    PivotedColumn
Вот горшок пустой, он предмет простой...
 
Спасибо большое всем
Страницы: 1
Читают тему (гостей: 1)
Наверх