Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск значения по 3м условиям
 
Необходимо подставить значения во все ячейки пустой таблицы ниже, при условии, что меняя год в выпадающем списке в нижней таблице, значения будут так же меняться на соответствующие в верхней таблице. Ситуация усложняется тем, что эти таблицы у меня находятся на разных листах, объектов в сотни раз больше и часто приходится менять объекты местами.

Сижу ломаю голову 4-ро суток...
 
Добрый день,
Код
=ЕСЛИ($B$17=2018;ИНДЕКС($C$4:$N$13;ПОИСКПОЗ($A18;$A$4:$A$13;0);ПОИСКПОЗ(C$16;$C$2:$N$2;0));ИНДЕКС($P$4:$AA$13;ПОИСКПОЗ($A18;$A$4:$A$13;0);ПОИСКПОЗ(C$16;$P$2:$AA$2;0)))
 
Спасибо, работает
 
В модуль листа Лист3
Код
Private Sub Worksheet_Change(ByVal Target As Range)
Dim FoundYear As Range
    If Not Intersect(Target, Range("B17")) Is Nothing Then
        Application.EnableEvents = False
     Set FoundYear = Rows(1).Find(Target, , xlValues, xlWhole)
      If Not FoundYear Is Nothing Then
        Range(Cells(FoundYear.Row + 3, FoundYear.Column), Cells(FoundYear.Row + 12, FoundYear.Column + 12)).Copy _
        Cells(Target.Row + 1, Target.Column + 1)
      End If
    End If
    Application.EnableEvents = True
End Sub
 
Kuzmich, Премного благодарен за макрос, завтра попробую ориентировать его под свою таблицу
Страницы: 1
Читают тему (гостей: 1)
Наверх