Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Почему ВПР не находит данные, которые есть в таблице?, Не находит данные.
 
Подскажите пожалуйста, в чём проблема

Задача:
с листа "мастер отчётов", столбца F (Площадка) подтянуть значения (адреса этих площадок) в лист 1, столбец I (Рся), поисковым запросом для этих площадок является столбец H "id объявления".
То есть вкратце. К каждому "id объявления" подтянуть адрес площадки с другого листа

Моя функция выглядит следующим образом:
Код
=VLOOKUP(H8;'Мастер отчётов'!A1:F328;6;0)

вроде все правильно, но выдаёт ошибку, что такого значения в диапазоне не найдено.

Подскажите пожалуйста, что я делаю не так!!!!
ошибка.jpg (22.21 КБ)
 
Ну раз говорит что нет - значит и впрямь нет!
Вы описание функции хоть даже в мастере внимательно читали? Вот прямо начиная с первых 6 слов...
http://prntscr.com/p4cwax
P.S. Там даже два раза это написано. А результат у меня есть потому что я поместил искомое значение туда, где его ищут.
Изменено: Hugo - 10 Сен 2019 19:48:27
 
В формуле не те диапазоны, что на самом деле. И в ТЕКСТОВЫХ (ЧИСЛОВЫХ) данных бесполезно искать ЧИСЛОВЫЕ (ТЕКСТОВЫЕ) значения. Надо либо учесть это в формуле, либо преобразовать данные в таблице.
*до исправления замечания модератора.
Код
=ВПР()
Изменено: Светлый - 10 Сен 2019 23:39:17
 
Это всё круто, но что именно мне нужно сделать???
 
Цитата
Светлый написал:
Название темы вполне подходит
Т.е. теперь все, у кого любая проблема с ВПР, могут смело писать сюда. Так?
 
Светлый, всё равно не работает.
есть еще варианты как это можно сделать?
 
название темы:
Почему ВПР не находит данные, которые есть в таблице?
ответ:
потому что их там нет
Если ВПР пишет #Н/Д - значит там нет ИСКОМЫХ ДАННЫХ. насколько бы искомое значение визуально не было похоже на находящееся в таблице
см. вложение в колонке А нет числа 3
понимаете число 3 - это число 3, а текст "3" - это текст состоящий из одного символа 3 а в ячейке и то и то выглядит как 3
Изменено: Ігор Гончаренко - 11 Сен 2019 02:20:12
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Цитата
Vadim_Zz написал:
всё равно не работает.есть еще варианты как это можно сделать?
Протянуть формулу вниз до ячеек, которые сработают.
 
Цитата
Vadim_Zz написал:
Светлый , всё равно не работает.есть еще варианты как это можно сделать?
Добрый день!
1) ВПР использует 1 столбец для поиска, поэтому в Вашем случае диапазон не со столбца "A", а с "D"
формула должны выглядеть так:
Код
=ВПР(H8;'Мастер отчётов'!$D$2:$F$328;3;0)

2) у Вас на листе "1" id объявления текстовое значение, на листе "Мастер отчетов" № Объявления - число
т.к. формат разный, то нужно либо их привести к единому формату, либо воспользоваться формулой массива, которая приведет все в один текстовый формат:
Код
=ВПР(ТЕКСТ(H8;"0" ;) ;ТЕКСТ('Мастер отчётов'!$D$2:$F$328;"0" ;) ;3;0)

после вставки формулы нажать Ctrl+Shift+Enter
и протянуть формулу
 
Цитата
Ігор Гончаренко написал:
потому что их там нетЕсли ВПР пишет #Н/Д - значит там нет ИСКОМЫХ ДАННЫХ. насколько бы искомое значение визуально не было похоже на находящееся в таблицесм. вложение в колонке А нет числа 3понимаете число 3 - это число 3, а текст "3" - это текст состоящий из одного символа 3 а в ячейке и то и то выглядит как 3
То есть ВПР не ищет по цифрам или нужно цифры перевести в формат текста?????
 
Цитата
Vadim_Zz написал:
То есть ВПР не ищет по цифрам или нужно цифры перевести в формат текста?????
Формат должен быть одинаковый, либо все числа, либо все текст. Или используйте вариант из моего поста выше.
 
Цитата
Vadim_Zz написал:
о есть ВПР не ищет по цифрам или нужно цифры перевести в формат текста?????
то есть цифра это и есть формат текста.
Вам несколько раз написали выше про текст и ЧИСЛО. А ЧИСЛО это не цифра.
 
Цитата
Vadim_Zz написал:
То есть ВПР не ищет по цифрам
т.е. ВПР ищет то, что написано найти (и тексты и цифры и даты и числа), а не то что Вы думаете найти
напишите в качестве искомого значения, то что есть в данных и ВПР найдет его и выдаст Вам соответствующие значение правее найденного
не пытайтесь искать по точному совпадению не существующие данные
глядя на прикрепленный мною выше пример, можно решить что в колонке А есть число 3 и ВПР(3;A:B;2;) должен вернуть b3. а не тут-то было
нет в колонке А числа 3, есть текст "3", который визуально от числа 3 не отличим, но фактически числом не является.
Изменено: Ігор Гончаренко - 11 Сен 2019 14:22:12
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
А можно ли написать универсальную формулу, которая будет решать вопрос "визуально похожих данных" при сравнении положительно?
Вот накидал пару вариантов (тест на 10 000 записей):
1.
Цитата
{=ВПР("'"&$G$1;"'"&$A:$A;1;0)}
- формула массива, результат выдает текстовый (два минуса), скорость -  239 сек (второе место по скорости, плюс)
2.
Цитата
=ВПР(--$G$1;A:A;1;0)
- поиск числа сохранненного как текст, только в числовом массиве (минус большой, т.к. фактически это не универсальная формула). скорость  0,42 сек (первое место по скорости, плюс)
3.
Цитата
=ПРОСМОТР(2;1/("'"&$A:$A="'"&$G$1);$A:$A)
- универсальная формула, которая ищет ВСЁ, в том числе и символы подстановки (к примеру такую строку "??2**6*??9A$SDD**G", большой плюс), скорость 449 сек (самая медленная из всех, минус)
4.
Цитата
=ИНДЕКС($A:$A;СУММПРОИЗВ(ПОИСКПОЗ("'"&$G$1;"'"&$A:$A;0)))
- ищет все кроме символов подстановки, по скорости 279 сек, третье место
Изменено: bedvit - 19 Сен 2019 17:14:02
«Бритва Оккама» или «Принцип Калашникова»?
 
Какие еще есть варианты (более быстрые, не формула массива)?
«Бритва Оккама» или «Принцип Калашникова»?
Страницы: 1
Читают тему (гостей: 2)
Наверх