Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Результат в зависимости от значений трех ячеек, Сравнение
 
Добрый день. Выручайте. Нужно прописать функцию которая считает: =ЕСЛИ(F2-D2=положительное то пусто, если F2-D2 = отрицательное то F2-1, если F2-C2 больше 10 то пусто, если F2-C2 меньше 10 то F2-1).
РАВНО НЕ НАДО! ))
Изменено: Olia_student - 12 Сен 2019 18:13:31
 
Может подойдет такая формула
Код
=IF(AND(F2-D2>0;F2-C2>10);"";IF(AND(F2-D2<0;F2-C2<10);F2-1))
 
Не работает((
ЕСЛИ(F2-D2=положительное   число то пусто, если F2-D2 = отрицательное число то F2 (от этого числа минус   1), если F2-C2 больше 10 то пусто, если F2-C2 меньше 10 то (от этого числа   минус 1).
 
А если цена конкурента меньше двух других?
и  F2-D2<0 и F2-C2<10?
 
Цитата
vikttur написал:
А если цена конкурента меньше двух других
xz :)
Код
=IF(OR(F2-D2>0;F2-C2>10);"";IF((F2-D2)<0;F2-1;IF((F2-C2)<=10;F2-1;"xz")))
Изменено: bigorq - 12 Сен 2019 18:40:28 (поменял AND на OR здесь OR(F2-D2>0;F2-C2>10))
 
bigorq, благодарю. Работает))

vikttur, данные могут меняться. Суть в том, чтобы поставить сравневая если F2(конкуренты) и D2 (цена (Б) положительное число то пусто,  если отрицательное между F2(конкуренты) и D2 (цена (Б)) то F2 (конкуренты) минус 1.
И так же если F2(конкуренты) - С2(Цена пр.) больше 10 то пусто, если F2(конкуренты) - С2(Цена пр.) меньше 10 то F2 (конкуренты) минус 1.  
 
Попробуйте в формуле jakim,  поменять and на or, тоже должно работать и запись короче  
Страницы: 1
Читают тему (гостей: 1)
Наверх