Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
SUMIFS формула, в которой в 1 из критериев 2-ое условие, по типу или-или.
 
Здравствуйте, друзья!

Нужен Ваш совет. Искал на форуме, есть схожие темы, но ответа не нашел.

Задача простая. Нужно подтянуть данные формулой SUMIFS. Но, в одном из критериев формулы, должно быть 2-ое условие, то есть как бы 2 критерия в 1 критерии.
Более детальное описание задачи во вложении-примере. Все расписано подробно. Надеюсь на Вашу помощь.

Заранее спасибо!
 
СуммЕСлиМн принимает только условие И. Для ИЛИ нужна другая функция, но названием темы вы урезали варианты ответов.
как вариант СуммЕСлиМн(1условие)+СуммЕСлиМн(2 условие)
Изменено: V - 20 Сен 2019 09:06:22
 
Цитата
Paul Zealand написал:
Задача простая
Так что ж вы её не решили?
Код
=СУММПРОИЗВ(($A$3:$A$13=I3)*($B$3:$B$13=J3)*($C$3:$C$13<=$F$1)*$D$3:$D$13)


для модераторов: суммирование по условию "дата не более" или пусто
Каждому For свой Next
 
V, а какое бы Вы предложили решение для этой задачи, без использования SUMIFS? Если оно сработает, я откорректирую вопрос и попрошу модераторов поменять тему.
 
Код
=СУММПРОИЗВ($D$3:$D$13*($A$3:$A$13=I3)*($B$3:$B$13=J3)*($C$3:$C$13<$F$1))
Изменено: Дмитрий(The_Prist) Щербаков - 20 Сен 2019 09:12:45
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Цитата
Paul Zealand написал:
без использования SUMIFS
#3 и #5 - найдите 10 отличий  :D
Каждому For свой Next
 
до кучи вариант в файле
Лень двигатель прогресса, доказано!!!
 
Цитата
Paul Zealand написал:
а какое бы Вы предложили решение для этой задач
buchlotnik уже все сделал, и название предложил и решение. пост #3.
вариант который предлагал во 2-ом посте
Код
СУММЕСЛИМН(D:D;A:A;I13;B:B;J13;C:C;"<"&$F$1)+СУММЕСЛИМН(D:D;A:A;I13;B:B;J13;C:C;"")
Изменено: V - 20 Сен 2019 09:24:58
 
Спасибо всем откликнувшимся! Спасибо buchlotnik, спасибо Дмитрий(The_Prist) Щербаков, спасибо Сергей.
Несколько альтернативных вариантов получено, задача решена!
Страницы: 1
Читают тему (гостей: 1)
Наверх