Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
ВПР из двух столбцов
 
Доброго времени суток!
Имеется общий список (столбец N в примере), к этому списку необходимо ВПРом подтянуть данные из двух таблиц (A:B и F:G), т.е. из B и G подтянуть в О, если #Н/Д или 0, то "-"
В таблице A:B, в данных могут быть пустые ячейки и отсутствовать точки из общего списка.
В таблице F:G, данные всегда заполнены, но отсутствуют точки из общего списка, постоянно меняются.
Как формулами это все сделать? голова кипит уже
 
Код
=ЕСЛИ(ЕСЛИОШИБКА(ЕСЛИОШИБКА(ВПР(N2;$A$2:$B$18;2;0);ВПР(N2;$F$2:$G$7;2;0));"-")=0;"-";ЕСЛИОШИБКА(ЕСЛИОШИБКА(ВПР(N2;$A$2:$B$18;2;0);ВПР(N2;$F$2:$G$7;2;0));"-"))
конечно это будет работать. но явно есть вариант лучше.  
Изменено: aibolit - 26 сен 2019 16:47:04
 
Adrich, а что делать если и там и там есть значения? или такое исключено?!
 
Цитата
aibolit написал:
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(ВПР(N2;A2:B18;2;0);ВПР(F2:G7;2;0));"-")
Не подтягивает данные из второй таблицы, вдобавок пустые ячейки нулями отображает
 
Mershik, не исключено, в примере есть такой пример, если значения есть в обоих таблицах они всегда одинаковые, ВПР берет одно из них.
 
Код
=ЕСЛИОШИБКА(ЕСЛИ(ВПР(N2;$A$1:$B$15;2;0)=0;ВПР(N2;$F$1:$G$6;2;0);ВПР(N2;$A$1:$B$15;2;0));"-")
 
Работает, я делал наоборот и поэтому не получалось, спасибо!
 
Adrich, вообще не должен) перепутал я свои наброски
Код
=ЕСЛИОШИБКА(ЕСЛИ(ЕНД(ВПР(N2;$A$1:$B$15;2;0));ВПР(N2;$F$1:$G$6;2;0);ЕСЛИ(ВПР(N2;$A$1:$B$15;2;0)=0;ЕСЛИ(ВПР(N2;$F$1:$G$6;2;0)="";"-";ВПР(N2;$F$1:$G$6;2;0));ВПР(N2;$A$1:$B$15;2;0)));"-")

Вот этот вроде рабочий
Изменено: Dark1589 - 26 сен 2019 17:41:52
 
Dark1589, работают оба варианта)
 
Adrich, там был косяк, при котором отсутствие искомого значения в A:B выдавало "-". В посте 8 формулу ещё чуть скорректировал
Страницы: 1
Читают тему (гостей: 1)
Наверх