Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
подсчет количества счетов по датам и оплаченным за месяц и год
 
Добрый всем день, помоги, не могу допетрить.
Задача:
1. подсчитать количество ячеек(счетов) в шт. за месяц и год.(например октябрь 19)
2. подсчитать количество ячеек(счетов) в шт. оплаченных за месяц и год (например октябрь 19)

посчитал сумму по таким счетам формулами:
Код
=СУММПРОИЗВ((ТЕКСТ(C15:C1048576;"ММММ ГГ")=E1)*L15:L1048576)
=СУММПРОИЗВ((ТЕКСТ(N15:N1048576;"ММММ ГГ")=E1)*(P15:P1048576="оплачен")*M15:M1048576)

где:
ячейки "С" - даты счетов в формате 01.01.19
ячейка E1 - отчетная дата (например: октябрь 19)
ячейки "L" - суммы счетов
ячейки "Р" - состояние счета "оплачен"
ячейки "М" - оплаченная сумма счетов (т.к. оплата может быть не полной)
Юный адепт культа УЧУД.
 
Судя по описанию задачи ее можно попробовать решить при помощи формулы СУММЕСЛИМН(), но без примера с несекретными исходными данными и желаемым результатом ПОДРОБНЕЕ сказать затруднительно.
Единственное, что кажется мне несколько избыточным - это суммирование результатов более миллиона произведений... Точно ли во всех просматриваемых ячейках хранятся значимые величины?  
 
Не следует путать цитату с бездумной копией [МОДЕРАТОР]

конечно не хранятся во всем диапазоне, это вы верно сказали, избыточно, но тут вопрос не в диапазоне, пусть хоть диапазон из 3 ячеек будет.

СУММПРОИЗВ заменил на СУММЕСЛИМН - пишет мало аргументов, я туп)
Юный адепт культа УЧУД.
 
Цитата
IKor написал:
Судя по описанию
не - по описанию СЧЁТЕСЛИМН()  ;)
Каждому For свой Next
 
да таже фигня пишет "мало аргументов", а можете подробно расписать?
Юный адепт культа УЧУД.
 
=СЧЁТЕСЛИМН(диапазон1; условие1; диапазон2; условие2; ....... и т.д.)

Просто количество диапазонов должно совпадать с количеством условий. Почитайте описание формулы, в Гугле все это есть.
 
Цитата
puna написал:
СУММПРОИЗВ заменил на СУММЕСЛИМН - пишет мало аргументов
У этих функций разный синтаксис - им нужны разные аргументы, записанные в определенном порядке.
Действительно следует почитать об этом в справке.
С другой стороны рекомендую Вам статью Как не забивать гвозди микроскопом с функцией СУММПРОИЗВ - возможно, некоторые идеи покажутся Вам интересными

buchlotnik, да
 
Цитата
puna написал:
можете подробно расписать
подробно расписано в справке по функции, я без файла-примера ничего расписывать не буду
Каждому For свой Next
 
Для buchlotnik файл во вложении.
Юный адепт культа УЧУД.
 
Цитата
puna написал:
1. подсчитать количество ячеек(счетов) в шт. за месяц и год.(например октябрь 19)
2. подсчитать количество ячеек(счетов) в шт. оплаченных за месяц и год (например октябрь 19)
1. один
2. один
Лень двигатель прогресса, доказано!!!
 
я Вас не понял)
Юный адепт культа УЧУД.
 
а че понимать то, исходя из примера там и формулы не нужны одна строка по первому вопросу один и по второму вопросу один счет

PS. хотите получить решение потрудитесь сделать для помогающих пример нормальный а не на от.....
Лень двигатель прогресса, доказано!!!
 
Сергей, Вы просто не поняли, диапазон может быть любой, хоть 1 ячейка, хоть 3, хоть 1млн.
я в первом сообщении описал задачу
Юный адепт культа УЧУД.
 
Цитата
puna написал:
=СУММПРОИЗВ((ТЕКСТ(C15:C1048576;"ММММ ГГ")=E1)*L15:L1048576)
=СУММПРОИЗВ((ТЕКСТ(N15:N1048576;"ММММ ГГ")=E1)*(P15:P1048576="оплачен")*M15:M1048576)
Код
=СУММПРОИЗВ(--(ТЕКСТ(C15:C1048576;"ММММ ГГ")=E1))
=СУММПРОИЗВ((ТЕКСТ(N15:N1048576;"ММММ ГГ")=E1)*(P15:P1048576="оплачен"))

я так понимаю разобраться как работает суммеслимн вы не хотите
Лень двигатель прогресса, доказано!!!
 
Разобраться хочу, только основная работа из-за этого стоит, а 10 минутным наскоком не получилось.
Юный адепт культа УЧУД.
 
из моего последнего сообщения формулы подошли?
Лень двигатель прогресса, доказано!!!
 
да, огонь, когда показывают решение - кажется все просто и логика формулы понятна, а когда делаешь сам сидишь днями)
Юный адепт культа УЧУД.
 
В продолжение темы, вроде так должно работать, но показывает 0.
Не кто не скажет где ошибка?

=СЧЁТЕСЛИМН(B15:B100;(ТЕКСТ(C15:C100;"ММММ ГГ")=E1))
=СЧЁТЕСЛИМН(B15:B100;(ТЕКСТ(C15:C100;"ММММ ГГ")=E1);B15:B100;P15:P100="оплачен")

где
ячейки В - это № счетов, которые собственно и считаю
Е1 - дата
ячейки Р - условие
Юный адепт культа УЧУД.
 
Цитата
Сергей написал:
я так понимаю разобраться как работает суммеслимн вы не хотите
с формулой то разобрался, она раз применима для подсчета количества?
Юный адепт культа УЧУД.
 
Так не прокатит читайте форум суммеслимн и счетеслимн с преобразованными массивами не работает и справку
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх