Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммировать рабочие часы в графике дежурств с 1 по 25 число.
 
Добрый день. Есть график дежурства. Все формулы работают. Считают всё. Дни недели, часы и т.д. Все рабочие формулы убрал оставил то, что не работает.
Пересмотрел в архиве ответа не нашёл. Суммирование работает только когда указан 1900 год при смене года суммирование не работает. Подскажите в чём причина.
 
Цитата
X.L.KAA написал:
Подскажите в чём причина.
в том, что у вас даты, а не числа - см. ваш файл с форматом ячеек общий
Каждому For свой Next
 
причина что надо сравнивать с датой а не просто числом
Код
=СУММЕСЛИМН(B21:AF21;B24:AF24;"=д";B18:AF18;"<"&ДАТА(B17;N17;25))
Лень двигатель прогресса, доказано!!!
 
Большое спасибо Сергей и buchlotnik всё подошло, считает.
 
Уже не первый раз сталкиваюсь с тем, что формула не работает в старом графике, а в новом на другом листе работает. Есть объяснение этому?
Страницы: 1
Читают тему (гостей: 1)
Наверх