Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вграфике дежурства формула не считает дни дежурства и часы по дням недели.
 
В график дежурства решил добавить учёт дней и часов по дням недели (выделено жёлтым). Формула не считает.
Как сделать так, чтобы формула распознавала дни недели.
Дни недели и числа в графике заданы для удобства формулой. Без формулы работает.
 
Попробуйте отображать день недели не форматом ячейки, а формулой;
=ТЕКСТ(B3;"ddd")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
количество дней посчитайте этой формулой
Код
=СУММПРОИЗВ((ДЕНЬНЕД(R4C2:R4C32;2)=(СТОЛБЕЦ()-34)/2)*(R10C2:R10C32="д"))
часы - аналогичной
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Максим В. работает но дни недели стали отображатьсься латинскими буквами. Формат ячейки не помог. Как поменять?
Изменено: X.L.KAA - 12 Ноя 2019 17:23:17
 
Игорь, Максим большое спасибо всё подошло, работает, буду применять.
 
Игорь формула для подсчёта времени такая же или её надо подправить?
 
там сумма а не счет ну и в дни недели попадать еще
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Перевод дней недели на русский нашёл у БМВ за 7 ноября 2018 по аналогии с азербайджанским и турецким. БМВ спасибо за подсказку.
Игорь с формулой для времени пока разбираюсь.  
Страницы: 1
Читают тему (гостей: 1)
Наверх