Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Получение сводной из значений, Получение количества
 
Всем привет!

Как получить итоговое количество бананов и кофе согласно примера?
 
50+10=60. Смотрите, как я быстро решил Вашу задачу :D
a4step, тема ни о чем. Представьте себя на месте другого человека, который первый раз увидел Вашу задачу и прочитайте Ваш вопрос - как из него можно понять, что Вы хотите сделать?
 
Давай-те усложним пример.
На первой картинке показал упрощенный вариант.
Есть сборка, в сборке есть подсборка, в подсборке есть подсборка 2-го уровня, в подсборке 2-го уровня - наименование.
Изменено: a4step - 13 Ноя 2019 08:10:37
 
суммеслимн() пробовали?
тест1.png (17.54 КБ)
 
Не вижу логики
 
Цитата
a4step написал:
Не вижу логики
в ваших примерах она тоже пока не наблюдается, желаемый результат какой и как получается
Лень двигатель прогресса, доказано!!!
 
Нужно если указан признак "0"-сборка, то "количество" признака "1" умножался на "количество" сборок признак "0".
Если указан признак "1", то умножался на на ЕДИНИЦУ / без изменений
Изменено: a4step - 13 Ноя 2019 09:14:14
 
в рамках реализации непонятного подхода формула массива в H6 и растянуть вниз
Код
=ЕСЛИОШИБКА(ПРОИЗВЕД(ЕСЛИ($E$6:$E$10*(($C$6:$C$10=C6)+($C$6:$C$10=G6)+($C$6:$C$10=ВПР(G6;$C$6:$G$10;5;0))+($C$6:$C$10=ЕСЛИОШИБКА(ВПР(ВПР(G6;$C$6:$G$10;5;0);$C$6:$G$10;5;0);)))=0;1;$E$6:$E$10*(($C$6:$C$10=C6)+($C$6:$C$10=G6)+($C$6:$C$10=ВПР(G6;$C$6:$G$10;5;0))+($C$6:$C$10=ЕСЛИОШИБКА(ВПР(ВПР(G6;$C$6:$G$10;5;0);$C$6:$G$10;5;0);)))));)
Лень двигатель прогресса, доказано!!!
 
Количество не считает
 
Формула МАССИВА
Лень двигатель прогресса, доказано!!!
 
Ctrl+Shift+Enter ?
 
м.б. проще всё?
 
сводная таблица, но выделять не всю таблицу. Такой вариант подойдет?

В строки столбец "1". В значение "Cумму по полю" столбца 4.
Изменено: Argo9 - 13 Ноя 2019 12:30:50
 
Цитата
Михаил Лебедев написал:
В строки столбец "1"
Спасибо большое! Я очень рад вашим решениям и формулам.
 
a4step, проверьте личку.
Страницы: 1
Читают тему (гостей: 1)
Наверх