Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчёт продаж товара по месяцам
 
Есть исходный файл ( в оригинале десятки тысяч строк, в примере короткая версия) в котором на листе1 расположена таблица статистика продаж за некий период (условно год) в ней все продажи расписаны построчно
Дата/время,  Название товара,   кол-во проданного

На листе2 в столбце А перечень всех товаров
В столбцах B,C,D и т.д. названия месяцев (янв.19, фев19 и т.д.)

Нужно чтобы столбцы B-M заполнились данными о продажах в этих месяцах. Т.е. в B2 кол-во проданного товара "товара1" за январь2019, в C2 кол-во проданного товара "товар3"

Пример прилагаю
P.S. не знаю важно это или нет, но вназваниях товаров встречаются разные знаки ",(,) !,№,@ и т.п - возможно это важно для использования каких-то формул
 
как-то так
=СУММПРОИЗВ((МЕСЯЦ('Исходные данные'!$B$2:$B$146)=МЕСЯЦ(N$1))*(ГОД('Исходные данные'!$B$2:$B$146)=ГОД(N$1))*('Исходные данные'!$C$2:$C$146=$B3)*'Исходные данные'!$D$2:$D$146)
Изменено: buchlotnik - 15 ноя 2019 00:54:11
Каждому For свой Next
 
Кнопка цитирования не для бездумного копирования [МОДЕРАТОР]

не получается
На листе1 сумма продаж = 2922, а на листе2 = 2676
а должны быть равны
Изменено: Сергий - 15 ноя 2019 01:34:25
 
А сводная таблица не подойдет? А формулами как считать 18 и 19 год по месяцам вместе?
Изменено: gling - 15 ноя 2019 01:34:44
 
Цитата
Сергий написал:
а должны быть равны
просто года не совпадают. ноя и дек - 18-го, а  не 19-го
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
 
Цитата
gling написал:
А сводная таблица не подойдет? А формулами как считать 18 и 19 год по месяцам вместе?
18 и 19 год нужно учитывать отдельно
 
А как сделать чтобы вместо месяцев в столбцах на листе "Результат" можно было задавать любой временной интервал.
Например СтолбецC -  1 января 2019-4 января 2019  
СтолбецD 5 января 2019-19 января 2019  
 
Цитата
Сергий написал:
18 и 19 год нужно учитывать отдельно
Цитата
Сергий написал:
а должны быть равны
вы уже определитесь
Каждому For свой Next
 
Цитата
Сергий написал:
А как сделать
А так и сделать, две ячейки начало периода- конец периода
Код
=СУММЕСЛИМН('Исходные данные'!$D$1:$D$146;'Исходные данные'!$C$1:$C$146;Результат!$B2;'Исходные данные'!$B$1:$B$146;">="&ячейка начала периода;'Исходные данные'!$B$1:$B$146;"<"&ячейка конец периода)

А что сводная не подходит? Если нажать на фильтр даты в сводной, можно выбирать любые периоды, поэксперементируйте.

Изменено: gling - 15 ноя 2019 12:11:20
 
Цитата
buchlotnik написал:
вы уже определитесь
Приношу извинения Я сначала не увидел, что в таблице на листе "Исходные данные" есть данные за ноябрь и декабрь 2018, соответственно на листе "Результат" месяца начинались с января 2019, поэтому сумма по продажам на этих листах разнятся
Изменено: Сергий - 15 ноя 2019 11:55:21
 
Цитата
gling написал:
А так и сделать, две ячейки начало периода- конец периода
В пример на лист "Результаты" добавил период 01.02.2019-10.02.2019, но не понимаю, как это вписать в формулу.
Файл приложил.
 
Я оправлял файл с другой формулой, в сообщении #9 написал как нужно сделать, вы даже не попробовали. Если хотите за 10 дней каждого месяца считать, то в формуле из сообщения #9 измените дату конца периода, обозначьте её как начало периода +10. Если создать ячейку в которой нужно будет заносить нужное количество дней, то конец периода будет "ячейка начала периода+ячейка с количеством дней".  
Изменено: gling - 15 ноя 2019 12:41:45
 
Приношу извинения, но я запутался.
Дело в том. что эти периода разные - т.е где то 10 дней, где-то 6, где 30
Например
с 1.01.2019 по 10.01.20.19
с 11.01.2019 по 31.01.20.19
с 1.02.2019 по 15.02.20.19
и.т.д.
Можно просто сделать в виде таблицы, где будут 2 строки
начало периода и конец периода, куда можно вносить вручную (не формулами) даты и столбец будет пересчитываться?
Пытаюсь сделать, но видимо не понимаю в сводных таблицах.
 
Привёл к тому виду, что надо, но формула почему-то считает не верно, то больше, то меньше, чем есть на самом деле
Почему-то все интервалы за  2018 год считает корректно, а все интервалы в 2019 некорретно
Изменено: Сергий - 15 ноя 2019 16:50:34
 
Вариант со сводной и временной шкалой. Куда еще проще?
Вот горшок пустой, он предмет простой...
 
Цитата
PooHkrd написал:
Вариант со сводной и временной шкалой. Куда еще проще?
А без сводной таблицы возможно?
Она у меня не редактируется -пишет нужна версия EXCEL в которой она была создана. И вообще честно говоря я в сводных таблицах не понимаю,  с формулами как-то привычнее, проще.
 
Цитата
Сергий написал: а все интервалы в 2019 некорретно
Сергий],все она корректно считает, а вот хранить данные в одной ячейке и дату и время это зло <#0> пример: по товар 1 формула не подтягивает значения в период с 01.11 по 31.11, т.к. в исходных данных у вас дата с временем, а в таблице только дата преобразуйте все ваши даты в числа и увидите, что критерий условия в формуле не выполняется, поэтому там пусто. Смотрите в файле, выделил красным по 1 товару. Решение простое либо привести исходные данные в порядок, либо добавить в итоговую таблицу дату с временем,
Изменено: Aleksey1107 - 15 ноя 2019 18:23:09
Страницы: 1
Читают тему (гостей: 1)
Наверх