Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как перемножить 2 строки с 2-мя условиями?
 
Добрый день!
Подскажите, пожалуйста... Необходимо посчитать среднее значение на промежуточную дату (к примеру на 01.03.20) для "Бюджет план", "Опер.план" и "Факт".
Через =СУММПРОИЗВ() не получается никак...
Изменено: azemov - 27 Ноя 2019 14:27:08
 
azemov, а где желаемый результат должен быть и в каком виде ? а среднее среди чегО? по жидкостям?
не знаю сделал как понял
Код
=СУММПРОИЗВ(($B$7:$B$10="литры")*($C$4:$AL$4=L$24)*$C$7:$AL$10)/СУММПРОИЗВ(($B$7:$B$10="литры")*($C$4:$AL$4=L$24))
Изменено: Mershik - 27 Ноя 2019 14:44:51
 
среднее значение чего
Лень двигатель прогресса, доказано!!!
 
Mershik
Сергей
желтым шрифтом, средний показатель градуса (%) допустим по 1-ой жидкости
Изменено: azemov - 27 Ноя 2019 14:51:09
 
в AR8 и растянуть в право
Код
=СРЗНАЧЕСЛИМН($C8:$AL8;$C$3:$AL$3;"<="&$AT$1;$C$4:$AL$4;AR$4)
Изменено: Сергей - 27 Ноя 2019 14:48:05
Лень двигатель прогресса, доказано!!!
 
формулу поменял забыл про  "<="&дата
Лень двигатель прогресса, доказано!!!
 
Сергей, спасибо, но не совсем.
Нужно среднее значение, но от количества...
Типа как в АМ8, только это необходимо вычислить на определенную дату (например на 01.03.20)
 
Цитата
azemov написал:
средний показатель градуса (%)
Цитата
azemov написал:
Нужно среднее значение, но от количества
:(
покажите в файле руками нарисуйте формулу как бы вы посчитали на куркуляторе и покажите в файле
Лень двигатель прогресса, доказано!!!
 
оно?
Код
=СУММПРОИЗВ((C7:AL7*C8:AL8)/СЧЁТЕСЛИМН($C$4:$AL$4;$AR$4;$C$3:$AL$3;"<"&$AT$1-25)/AR7;($C$4:$AL$4=$AR$4)*($C$3:$AL$3<$AT$1-25))
 
Сергей,
=(C7*C8+F7*F8+I7*I8+L7*L8+O7*O8+R7*R8+U7*U8+X7*X8+AA7*AA8+AD7*AD8+AG7*AG8+AJ7*AJ8)/AR7

Вижу это так...
Зачеркнул то, что не должно считаться, т.к. считаем на 01.03.20
 
Андрей Лящук, спасибо, но должно получиться 37,5 % в AR8
пытаюсь найти ошибку...
 
azemov, всмысле должно
Цитата
azemov написал:
получиться 37,5 % в AR8
если в
Цитата
azemov написал:
=(C7*C8+F7*F8
получается =(C7*C8+F7*F8) = 15750
 
и еще разделить на AR7

(C7*C8+F7*F8) / AR7
 
Андрей Лящук,
не совсем верно, полученное значение делится на кол-во ячеек, удовлетворяющих условия... а должно делиться на AR7 (сумма литров за период)
 
azemov,
Код
=СУММПРОИЗВ(($C$4:$AL$4=AR$4)*($C$3:$AL$3<$AT$1)*C8:AL8*(($C$4:$AL$4=AR$4)*($C$3:$AL$3<$AT$1)*C7:AL7))/СУММЕСЛИМН(C7:AL7;$C$4:$AL$4;$AR$4;$C$3:$AL$3;"<"&$AT$1-25)
 
Mershik,
Спасибо огромное, Вы мой спаситель!!! :D  
 
azemov, в будущем просто в файле покажите то что должно получится и рядом как это считате ручками и все....
Страницы: 1
Читают тему (гостей: 1)
Наверх