Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Из текстовой строки надо большему числу присвоить значение "1", а меньшему числу значение "2".
 
Здравствуйте.
Есть текстовая строка с такой записью:
3:2 (24:26, 25:16, 24:26, 25:13, 15:9)

Требуется сделать следующее:
Первая ячейка: "3:2". Первое число больше, чем второе. Т.е. в первой ячейке должна быть цифра "1".
Вторая ячейка: "24:26". Второе число больше, чем первое. Т.е. во второй ячейке должна быть цифра "2".
Третья ячейка: "25:16". Первое число больше, чем второе. Т.е. в третьей ячейке должна быть цифра "1".
и т.д.

В файлике пример.
Подскажите, плиз, если возможно, конечно. Заранее благодарю.  
 
По быстрому слепилось
=(--MID(SUBSTITUTE(" "&SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(SUBSTITUTE($A1;"(";);")";);",";);":";" ");" ";REPT(" ";99));((COLUMN(A1)-1)*2+1)*99;99) < --MID(SUBSTITUTE(" "&SUBSTITUTE(SUBSTITUTE(SUBSTITUTE(SUBSTITUTE($A1;"(";);")";);",";);":";" ");" ";REPT(" ";99));((COLUMN(A1)-1)*2+2)*99;99))+1
Можно подсократить, но лень.
По вопросам из тем форума, личку не читаю.
 
Код
Function MoreThen(s)
  Dim re, ms, rz, i&
  Set re = CreateObject("VBScript.RegExp"): re.Global = True: re.Pattern = "\d+>\d+"
  s = Replace(s, ":", ">"):  If Not re.test(s) Then Exit Function
  Set ms = re.Execute(s): ReDim rz(1 To 1, 1 To ms.Count)
  For i = 1 To ms.Count
    rz(1, i) = 1 + IIf(Evaluate("=" & ms(i - 1)), 0, 1)
  Next
  MoreThen = rz
End Function
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
.
Код
=ЕСЛИ(--СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ($A$1;"(";ПОВТОР(" ";20));",";ПОВТОР(" ";20));")";"");24*СТОЛБЕЦ(A1)-23;24);":";ПОВТОР(" ";99));1;99))>--СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ($A$1;"(";ПОВТОР(" ";20));",";ПОВТОР(" ";20));")";"");24*СТОЛБЕЦ(A1)-23;24);":";ПОВТОР(" ";99));50;99));1;2)
 
artyrH, тримером перед -- проходить не обязательно.
По вопросам из тем форума, личку не читаю.
 
БМВ, да, все верно
 
Всем огромное спасибо.
Страницы: 1
Читают тему (гостей: 1)
Наверх