Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Найти значение по нескольким условиям.
 
Время доброго. Возможно найти нужное значение по нескольким параметрам. В столбце (А) найти наибольшее, если в столбце (B) значение больше (0), нужно показать значение из столбца (D).  Если значение в столбце (B) меньше ( 0 ) нужно показать значение из столбца ( C ). Файл пример.
Изменено: yrikovsy - 4 Дек 2019 14:03:23
 
Цитата
yrikovsy написал:
если в столбце (B) значение больше (0), нужно показать значение из столбца (D).  Если значение в столбце (B) меньше ( 0 ) нужно показать значение из столбца ( C )
а зачем искать наибольшее в столбце А?
 
А если равно нолю  
 
Это вариант не рассматривал так как очень редкий вариант такой.

Цитата
artyrH написал: а зачем искать наибольшее в столбце А?
Чтобы найти нужное число.
 
Цитата
yrikovsy написал:
Что бы найти нужное число
Ok :)  вы лучше бы заполнили несколько строк желаемого столбца,  а дальше уже легче будет догадаться
 
yrikovsy,
Код
=ИНДЕКС($C$13:$D$57;ПОИСКПОЗ(НАИБОЛЬШИЙ($A$13:$A$57;1);$A$13:$A$57;0);ЕСЛИ(ИНДЕКС($B$13:$B$57;ПОИСКПОЗ(НАИБОЛЬШИЙ($A$13:$A$57;1);$A$13:$A$57;0);1)>0;2;1))
 
Цитата
msi2102 написал:
А если равно нолю  
присоединяюсь,
а так
=VLOOKUP(MAX(A13:A57);A13:D57;2+(VLOOKUP(MAX(A13:A57);A13:D57;2;)>0);)
Изменено: БМВ - 4 Дек 2019 14:15:59
По вопросам из тем форума, личку не читаю.
 
Mershik спасибо большое, работает.
 
Цитата
БМВ написал:
присоединяюсь, а так=VLOOKUP(MAX(A13:A57);A13:D57;2+(VLOOKUP(MAX(A13:A57);A13:D57;2;)>0)
БМВ привет, спасибо, но так не работает, хватит варианта Mershik.
 
Цитата
yrikovsy написал:
но так не работает
надеюсь на русский перевели?
По вопросам из тем форума, личку не читаю.
Страницы: 1
Читают тему (гостей: 1)
Наверх