Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Копирование ячеек из определенных "разделов", Создал новую тему
 
(по вложенному примеру будет понятнее)

Есть разделы :
раздел ЛЕНОВО
раздел ОСТАЛЬНОЕ
раздел ГРАФИКА
раздел КОМПОНЕНТЫ
раздел РАБОТЫ

в каждом разделе есть много строк с инфой. Разделяются между собой разделы только 1 строкой голубого цвета с суммой.
Нужно чтобы копировались и перемещались столбики B-F с данными только из раздела ЛЕНОВО, ГРАФИКА и КОМПОНЕНТЫ на ячейку B150.

Вся сложность в том, что количество строк в разделах меняется каждую неделю, и поэтому нужно как-то выделять строки из разделов по ту самую голубую\пустую строку. И в итоге на B150 чтоб был обычный список из трёх разделов, без названий разделов.

Во вложении есть таблица и под ней пример, как должно делаться  :D  
 
См. вариант. Хочу заметить, что размещать итоговую таблицу под исходными данными - не самый лучший вариант. Лучше это делать справа или вообще на отдельном листе.
 
урссс... Юрий М, уже дал вариант, свои вопросы снимаю.
Изменено: Михаил Витальевич С. - 4 Дек 2019 20:42:23
 
в b150
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$1:B$150;АГРЕГАТ(15;6;СТРОКА($A$1:$A$148)/($B$1:$B$148<>"")/(($A$1:$A$148>1)*($A$1:$A$148<ПРОСМОТР(2;1/("ОСТАЛЬНОЕ"=$B$1:$B$148);$A$1:$A$148))+($A$1:$A$148>ПРОСМОТР(2;1/("ГРАФИКА"=$B$1:$B$148);$A$1:$A$148))*($B$1:$B$148<>"КОМПОНЕНТЫ")*($A$1:$A$148<ПРОСМОТР(2;1/("РАБОТЫ"=$B$1:$B$148);$A$1:$A$148)));СТРОКА(A1)));"")
Изменено: artyrH - 4 Дек 2019 22:05:11
 
Юрий М, просто СУПЕР!!)
спасибо!
Страницы: 1
Читают тему (гостей: 1)
Наверх