Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как узнать количество переменных при использовании фильтра?
 
Добрый вечер!

Подскажите, пожалуйста.
У меня возникла следующая проблема, работаю с большой базой, но смоделировала проблему на маленькой таблице. Допустим, у меня есть два столбца, класс и фамилия ученика. Я ставлю фильтр для 1 класса, вижу несколько фамилий, некоторые из которых повторяются. Мне нужно знать сколько разных фамилий в классе, а не человек.

Как это сделать? В фильтре не указано их число (в данном случае понятно, что их 3, но если бы было 20, то визуально уже не определить, пришлось бы считать).

Спасибо!
1.png (58.32 КБ)
2.png (52.73 КБ)
Изменено: casablanca - 4 Дек 2019 21:45:50
 
Привет!

Функция СЧЁТЕСЛИ
 
Inexsu, как я понял, casablanca, нужно немного другое.
casablanca, Как вариант - см.файл
Возможны и другие варианты.
 
нам нужно узнать длину списка значений, из которых составлено данное множество?
формула массива:
Код
=СУММ(1/СЧЁТЕСЛИ(A2:A11;A2:A11))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
casablanca, см. файл во вложении. Решение с доп.столбцами.
 
Цитата
casablanca: Как узнать количество переменных при использовании фильтра?
лучше "Количество уникальных значений отфильтрованного диапазона" — поиском по этой фразе много чего интересного найдёте  ;)
Изменено: Jack Famous - 5 Дек 2019 11:50:53
«Тот, кто несет фонарь, спотыкается чаще, чем тот, кто идет следом.»
Иоганн Пауль Фридрих Рихтер
Страницы: 1
Читают тему (гостей: 1)
Наверх