Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
ВПР по части текста
 
Привет!
Пытаюсь решить такую проблему:
Есть таблица
EmailНазваниеГородКатегорииТелефонАдрес

Пытался решить вопрос через ВПР
1. Разделил адреса через запятую в разные колонки
2. вынес их в отдельный файл и соединил все в 1 колонку
3. через ВПР пытался подставить к каждой почте свои данные, но это работает только при условии, что в ячейке таблица с которой мы сравниваем только 1 емайл. с 2 не получается
Изменено: Alex_dark74 - 6 Дек 2019 19:00:38
 
Памагите мои глаза :'(
Изменено: Wild.Godlike - 6 Дек 2019 17:11:40
 
Добрый день.
Я искренне восхищен упорством, с которым сделан "пример" исходной таблицы и таблицы результата, но неужели нельзя было просто файл-пример сделать и приложить к сообщению. В формате Excel? :) Из него (файла-примера) сразу бы видно было, например, с какой строки какого столбца нарисованы данные. А из вашего труда этого не видно. А это важно.
Кому решение нужно - тот пример и рисует.
 
Файл-пример надо показывать. И реальные адреса, телефоны не надо выкладывать на всеобщее обозрение.

Цитата
через ВПР пытался
А если с этой функцией не решить? Зачем в названии темы обозначать ущербный путь решения? название должно отражать задачу.
Предлагайте. модераторы заменят
 
Цитата
Пытливый написал:
Я искренне восхищен упорством, с которым сделан "пример"
:D  
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Извините!
Вот файл, ну точнее часть файла
 
О данных на общее обозрение - не поняли? Сеть -она такая... потом еще виноваты будете. Создайте пример с отвлеченными данными, прикрепите в первому собщению. Само сообщение тже отредактируйте

В сообщении №4 и о названии темы замечание...
 
Alex_dark74, ой
Изменено: Mershik - 6 Дек 2019 18:53:25
 
Цитата
vikttur написал:
О данных на общее обозрение - не поняли?
Понял. Я тут первый раз на форуме. Сорян
 
Да при чем здесь форум? не нужно светить в сети реальные телефоны и адреса.  Это касается и файла
И название темы предложите
 
Вот ответ на название темы и на первый пост:
Код
=ВПР("*"&A2&"*";$M$2:$O$31;2;0)
Изменено: Hugo - 6 Дек 2019 21:06:49
Страницы: 1
Читают тему (гостей: 1)
Наверх