Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Количество заказов работника с отсеиванием по условию
 
Добрый вечер.
Очень нужна помощь.

Я прикрепила файл. Моя задача показать количество (и номер- обязательно) выполненных заказов по работнику Морозову с табельным номером 1111 в столбце "Н" списком (подряд, друг за другом). Я прописала функции, с этим все окей. Но прошу помочь со следующим: если в столбце "Е" (заказ) указаны символы "-" или "б", то мне нужно, что бы по этому человеку в столбец "Н" ничего не тянулось. То есть в столбец "Н" идут только номера заказов (подряд, без пробелов) без каких либо других символов.

Что мне необходимо прописать в формулу?  
 
Помогаю: ознакомьтесь с правилами форума, предложите новое название темы. Модераторы заменят.
 
vikttur, Мелкий женоненавистник :-)

=IFERROR(INDEX($E$5:$E$10;SMALL(IF(($C$5:$C$10=$H$3)*ISNUMBER(--E5:E10);ROW($C$5:$C$10)-ROW($C$5)+1);ROW()-ROW($H$5)+1));"")
Изменено: БМВ - 10 дек 2019 19:44:48
По вопросам из тем форума, личку не читаю.
 
название темы: выбрать значения по трем условиям
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$1:$E$10;НАИМЕНЬШИЙ(ЕСЛИ($C$5:$C$10=$H$3;ЕСЛИ(ЕЧИСЛО(--$E$5:$E$10);ЕСЛИ($D$5:$D$10="Морозов";СТРОКА($E$5:$E$10))));СТРОКА(C1)));"")
 
Цитата
БМВ написал: Мелкий женоненавистник
А кое-кто большой, лохматый. и ленивый. Формулы писать - как семечки щелкать, а название не может придумать :)
 
ещё вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС($E$5:$E$10;АГРЕГАТ(15;6;(СТРОКА($C$5:$C$10)-4)/(ЕЧИСЛО(--($E$5:$E$10)))/($C$5:$C$10=$H$3);СТРОКА(A1)));"")
 
для разнообразия:
Код
 =ЕСЛИОШИБКА(ИНДЕКС($E$5:$E$10;НАИМЕНЬШИЙ(ЕСЛИ(ЕОШ($E$5:$E$10/($C$5:$C$10=$H$3));"";СТРОКА($A$1:$A$6));СТРОКА(A1)));"")
Каждому For свой Next
 
Появились новые задачи.
1. Все мои заказы указываются в формате "текст", т.к. есть заказы начинающиеся с нуля. Функция Ечисло не помогает.
2. И часто заказы у одного и того же человека дублируются. Не могу понять, что можно прописать, что бы подтягивались только уникальные значения (заказы).
 
Цитата
Alex23195 написал:
Появились новые задачи
спасибо конешно
 
Alex23195, =ЕСЛИОШИБКА(ИНДЕКС($E$5:$E$10;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ($H$4:H4;$E$5:$E$10)=0)/(($D$5:$D$10=$H$2)*($H$3=$C$5:$C$10)*($E$5:$E$10<>"-")*($E$5:$E$10<>"б"));0);0));"")
 
Как здесь ответить конкретному человеку? =))

Mershik, а если нам не трогать диапазон $D$5:$D$10? Фамилии ни какой роли не играют. Я их скрою.  
 
Alex23195, как ответить - нажать "на имя"


ну если
Цитата
Alex23195 написал:
Фамилии ни какой роли не играют.
то их убрать и условий и все буде работать на основании номера и "б" и "-"
Изменено: Mershik - 19 дек 2019 10:07:36
Страницы: 1
Читают тему (гостей: 1)
Наверх