Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммирование значений по диапазону дат
 
Здравствуйте!

Помогите подобрать формулу.
Возникла проблема при ссылке на ячейку с датой, формула распознает ее как набор цифр, а нужно чтобы суммировала все значения по фамилии и по месяцу (например, "Иванов" и "ноябрь 2018" должно получиться "18", а мне пишет "0"). Файл прикрепляю. На самом деле условий гораздо больше, но заморочка только в дате у меня, все остальное работает. Важно, чтобы в ячейке с датой полностью была прописана дата - Число.Месяц.Год (можно и цифрами, и буквами). Понимаю, что возможно дело в форматах, но и этого я не понимаю((

Помогите, пожалуйста!
 
=СУММЕСЛИМН(A2:A7;B2:B7;"Иванов";C2:C7;">=01.11.2018";C2:C7;"<=30.11.2018")
В ячейке D1 дата - первое число месяца:
=СУММЕСЛИМН(A2:A7;B2:B7;"Иванов";C2:C7;">="&D1;C2:C7;"<="&КОНМЕСЯЦА(D1;0))
 
Разобралась. Все получилось)) Огромное спасибо!
Страницы: 1
Читают тему (гостей: 1)
Наверх