Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
помогите преобразовать данные с интервалом в 8 столбцов
 
Всем доброго времени суток:)
Есть база exel в которой значения повторяются через каждые 8 столбцов, необходимо сделать следующее:
Каждые 7 столбцов транспонировать в строки.
Привести к виду по 7 строк и перенести туда данные.Каким способом это лучше сделать? :qstn:
Нужна формула для этого преобразования.
Изменено: SafR - 5 Янв 2020 11:39:56
 
.
Код
=ИНДЕКС(данные!$3:$3;СТОЛБЕЦ(A1)*8+СТРОКА(A1)+2)
 
Цитата
safr341 написал:
Есть
Цитата
safr341 написал:
необходимо
Цитата
safr341 написал:
Привести
Цитата
safr341 написал:
Нужна
А здороваться не нужно? Или только задачи ставить?
 
Оу, прошу прощения. Всем добрый день, приятных праздников и счастливого нового года :) Премного благодарен за помощь!
Изменено: SafR - 5 Янв 2020 11:39:24
 
еще формулу в С3
Код
=ЕСЛИОШИБКА(ИНДЕКС(данные!$A$1:$CE$1000;ОКРВВЕРХ((СТРОКА(A1))/7;1)+2;СТОЛБЕЦ(A2)*8+СТРОКА(A2)+1+ОКРВВЕРХ((СТРОКА(A1))/7;1));"")
Страницы: 1
Читают тему (гостей: 1)
Наверх