Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Рассчитать разницу с учётом рабочего времени
 
Добрый день!
Ищу помощи с решением задачи.
Дано: две единицы времени формата дата/время (условно 25.12.19 16:38:09 и 27.12.19 10:47:46).
Нужно рассчитать разницу с учётом рабочего времени (с 9:00 до 21:00).
можете подсказать функцию, с помощью которой можно это сделать? Своими силами ковырялся, но все вхолостую.
 
С учетом - это значит с исключением? )
 
Верно, нужно исключить из подсчета период с 21:00 до 09:00.
 
А эти единицы могут выходить за границу рабочего времени? Например 25.12.19 6:38:09 или 27.12.19 22:47:46
И ещё глупый вопрос: а разницу в чём выдавать? Дни:часы:минуты или просто часы:минуты?
Изменено: Wiss - 14 Янв 2020 17:21:40
Я не волшебник, я только учусь.
 
Учитывать - оказывается, наоборот, исключать...
Цитата
tarnkryze написал: с 9:00 до 21:00
оказывается, работают ночью
Цитата
исключить из подсчета период с 21:00 до 09:00.

Вы нормально описать задачу можете?
 
>>>А эти единицы могут выходить за границу рабочего времени? Например 25.12.19 6:38:09 или 27.12.19 22:47:46
Да, могут выходить за границу рабочего времени.
>>>И ещё глупый вопрос: а разницу в чём выдавать? Дни:часы:минуты или просто часы:минуты?
Разница нужна в формате Часы:минуты:секунды.
 
>>>оказывается, работают ночью
Нвоборот. Работаем днём, с 9:00 до 21:00. В рабочие часы таймер тикает, вне рабочие не тикает.
вероятно, я не очень удачно выбрал глагол :(
 
Так, сформулируйте просто. Вы хотите посчитать сколько рабочего времени проработали между двумя датам или наоборот сколько НЕ работали между двумя датами???
 
Изи
Ответ в секундах.
=ЕСЛИ(A2>A3;"Ошибка первая дата больше";ЕСЛИ(A3>=1+ДАТА(ГОД(A2);МЕСЯЦ(A2);ДЕНЬ(A2));ЕСЛИ(ЧАС(A2)<22;21*3600-МАКС(ЧАС(A2)*3600+МИНУТЫ(A2)*60+СЕКУНДЫ(A2);9*3600);0)+ЕСЛИ(ЧАС(A3)>8;МИН(ЧАС(A3)*3600+МИНУТЫ(A3)*60+СЕКУНДЫ(A3);21*3600)-9*3600;0)+(ОТБР(A3;0)-ОТБР(A2;0)-1)*(21-9)*3600;МИН(ЧАС(A3)*3600+МИНУТЫ(A3)*60+СЕКУНДЫ(A3);21*3600)-МАКС(ЧАС(A2)*3600+МИНУТЫ(A2)*60+СЕКУНДЫ(A2);9*3600)))
Изменено: Wiss - 14 Янв 2020 18:03:26
Я не волшебник, я только учусь.
 
Wiss, спасибо огромное! То, что нужно.

И всем остальным тоже спасибо за участие)
 
Так что считали? Только рабочее время?
Цитата
tarnkryze написал: В рабочие часы таймер тикает, вне рабочие не тикает
Если да, то при чем здесь разница?
Страницы: 1
Читают тему (гостей: 1)
Наверх