Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
На другой лист выбрать Фамилии только тех, кому 33 года
 
Добрый вечер,

Как можно отфильтровать столбец, выбрав только Фамилии тех, кому 33 года?
Для примера сделала файл.
И с него хочу вывести на второй странице одну колонку с ФИО только тех, кому 33 года.  
 
Цитата
Anastas'a написал: хочу вывести на второй странице
Расширенным фильтром. Вызывать его с листа, на который собираетесь вывести отфильрованное.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Обычным фильтром, а потом копировать и вставить
Мастерство программиста не в том, чтобы писать программы, работающие без ошибок.
А в том, чтобы писать программы, работающие при любом количестве ошибок.
 
 Z, Спасибо) Но, у меня как-то не получилось, потому что расширенный фильтр скрывает строки... а мне нужны строки подряд
Alemox,  Когда это большие таблицы неудобно.

И думала именно о формуле,что бы можно было быстро поменять само условие фильтра (тут 33 года).
Изменено: Anastas'a - 22 Янв 2020 19:08:03
 
сводная
Мастерство программиста не в том, чтобы писать программы, работающие без ошибок.
А в том, чтобы писать программы, работающие при любом количестве ошибок.
 
Добрый вечер,
Если Вы счастливый обладатель офис 365, тогда совсем просто:
=ФИЛЬТР(RC[-9]:R[33]C[-9];RC[-8]:R[33]C[-8]=R[-1]C[2];"Возраст отсутствует в исходный данных")
 
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Sheet1!A:A;НАИМЕНЬШИЙ(ЕСЛИ(33=Sheet1!B$2:B$39;СТРОКА($2:$39));СТРОКА(A1)));"")
Страницы: 1
Читают тему (гостей: 1)
Наверх