Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Задвоить строки двумерного массива
 
Здравствуйте. Искала, не нашла. Может под другим названием надо было искать. Подскажите, пожалуйста, как сделать автоматически:
Есть условие (каждое слово в отдельной ячейке)
Слово1 Слово1 Слово1
Слово2 Слово2 Слово2
Слово3 Слово3 Слово3
Слово4 Слово4 Слово4

Необходимо сделать
Слово1 Слово1 Слово1
Слово1 Слово1 Слово1
Слово2 Слово2 Слово2
Слово2 Слово2 Слово2
Слово3 Слово3 Слово3
Слово3 Слово3 Слово3
Слово4 Слово4 Слово4
Слово4 Слово4 Слово4

Какое-то время я ручками копировала, но объем данных вырос и не успеваю. Может есть формула? Подскажите, пожалуйста.
Изменено: Madonna7 - 28 Янв 2020 11:48:39 (Вложила файл)
 
Ознакомьтесь с правилами, выложите файл-пример. Вероятно, кто-нить поможет. Формулами это решается. Я бы делал через ДВССЫЛ, ОКРУГЛ и СТРОКА.
Я не волшебник, я только учусь.
 
Название темы: Задвоить строки двумерного массива.
=ИНДЕКС($B$2:$D$5;ЦЕЛОЕ((СТРОКА(F1)-1)/2)+1;СТОЛБЕЦ(A1))
Изменено: Максим В. - 28 Янв 2020 11:51:59
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
=ДВССЫЛ("B"&ОТБР((СТРОКА(A1)-1)/2+СТРОКА($B$2);0))
Я не волшебник, я только учусь.
 
=ДВССЫЛ(АДРЕС(СТРОКА()/2-2;СТОЛБЕЦ()-4))
=СМЕЩ($B$2;СТРОКА()/2-4;СТОЛБЕЦ()-6)
=ИНДЕКС($B:$D;СТРОКА()/2-2;СТОЛБЕЦ()-5)
 
Если ячеек с данными в строке по горизонтали больше, то формулы не растягиваются. Может быть мой Excel плохо работает?  
Изменено: Madonna7 - 28 Янв 2020 13:26:17
 
В этой формуле:
=ИНДЕКС($B$2:$D$5;СТРОКА(F2)/2;СТОЛБЕЦ(A8))
измените первый аргумент под Ваш массив.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
Максим В. написал:
В этой формуле:=ИНДЕКС($B$2:$D$5;СТРОКА(F2)/2;СТОЛБЕЦ(A8))измените первый аргумент под Ваш массив.
Спасибо, получилось. Мне любопытно, что значит СТРОКА(F2), СТОЛБЕЦ(А8). Почему именно эти значения, а не А9 и Z5?
 
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    Пользовательский1 = Table.Repeat(Источник, 2),
    #"Сортированные строки" = Table.Sort(Пользовательский1,{{"parole", Order.Ascending}})
in
    #"Сортированные строки"
 
СТРОКА(F2) вернет номер строки 2, при протягивании вниз 3,4,5 и т.д.
СТОЛБЕЦ(А8) вернет 1, при протягивании вправо 2,3,4 и т.д.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1
Читают тему (гостей: 1)
Наверх