Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Суммировать значения из разных колонок в зависимости от условия (периода)
 
Добрый день!
Подскажите пожалуйста, как должна выглядеть формула в ячейке N3, чтобы получить сумму данных в зависимости от выбранного клиента (ячейка M3) в заданный диапазон недель (ячейки K1, L1). Пример прикладываю.

спасибо!
caustic
 
еще раз всем привет! покопался в интернете и нашел вариант, который видоизменил под свой случай.

всем спасибо!
Код
=СУММПРОИЗВ(($A$5:$A$14=M3)*($B$4:$H$4>=K1)*($B$4:$H$4<=L1)*$B$5:$H$14)
caustic
 
Еще вариант. Массивная
Код
=СУММ(ИНДЕКС(ЕСЛИ((B4:H4>=ПОИСКПОЗ(K1;B4:H4;))*(B4:H4<=ПОИСКПОЗ(L1;B4:H4;));B5:H14);ПОИСКПОЗ(M3;A5:A14;)))
Изменено: abc1 - 13 Фев 2020 12:14:19
 
До кучи:
=СУММЕСЛИМН(ИНДЕКС(B5:H14;ПОИСКПОЗ(M3;A5:A14;);0);B4:H4;">="&K1;B4:H4;"<="&L1)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1
Читают тему (гостей: 1)
Наверх