Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выбор значения исходя из определенного диапазона значений
 
Всем привет очень интересно как можно использовать формулу в данной ситуации, за любую оказанную помощь буду очень сильно благодарен ))
Есть определенный набор цифр 183; 31 ; 14;88;15
И нужно что бы эксель выбирал значение исходя из диапозона значений, а именно:

От 70 до 100 и выше – 1;
От 20 до 70 – 0,7;
От 5 до 20 – 0,45
От 1 до 5 -0,15
Вопрос как это лучше сделать если в Если нельзя делать двойные выражение прямо в формуле, а если писать просто как =>(больше или равно) то он отталкивается от самого большого значения и его вписывает в ячейку.
p.s. у меня старый эксель и нету функции еслимн
Изменено: VeberVik - 18 Мар 2020 14:38:50
 
Используйте ВПР с нечетким поиском. Таблица с нижними границами и нужным результатом для поиска и ВПР([что ищем];[где ищем];2;1)
 
VeberVik, если изменить чуть таблицу с коэф.
Код
=ИНДЕКС($E$2:$E$6;ПОИСКПОЗ(A1;$D$2:$D$6;-1);1)
 
Спасибо всем )

3.PNG (9.64 КБ)
Изменено: VeberVik - 18 Мар 2020 14:40:14
 
VeberVik, а так?
=ЕСЛИ(И(A1>=1;A1<5);0,15;ЕСЛИ(A1<20;0,45;ЕСЛИ(A1<70;0,7;1)))
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Максим В.,да подходит , спасибо за разнообразные варианты !)
Страницы: 1
Читают тему (гостей: 1)
Наверх