Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Подсчет строчного среднего или сумму по 2-ум критериям, Подсчет данных
 
Прошу помощи с подсчетом среднего значение или суммы построчно но по 2 ум критериям.
Есть гугл таблица которая собирает ответы с гугл форм на лист 2 надо вывести среднее или формулу суммирования но по конкретным критериям, это рабочее место и месяц. При добавлении формулы в конце всей таблицы, формула уделяется при поступлении новых ответов.
 
ZhdanovYUYU, массивная формула
Код
=СУММ(ЕСЛИ(('Ответы на форму (1)'!$D$2:$D$15=$A2)*(МЕСЯЦ('Ответы на форму (1)'!$A$2:$A$15)=МЕСЯЦ(--("1"&B$1&"1901")));'Ответы на форму (1)'!$E$2:$V$15))
 
Формула выдала сумму всего диапазона и получилось 1136 Не пошло(((
Должно получится 89 и по итогу я просто поделил-бы на 18 и получил среднее

Строчного суммирования не могу найти да и еще по двум критериям
 
Цитата
ZhdanovYUYU написал:
Не пошло(
так это у вас не пошло
 
Цитата
Михаил Л написал:
так это у вас не  пошло
Я Лош....ра!!!!
Забыл нажать Ctrl + Shift + Enter.
Прошу прощения!!!!!!!!!!!
 
можно попроще
Код
=СУММПРОИЗВ(('Ответы на форму (1)'!$D$2:$D$15=$A2)*('Ответы на форму (1)'!$C$2:$C$15=B$1)*'Ответы на форму (1)'!$E$2:$V$15)
Лень двигатель прогресса, доказано!!!
 
Цитата
Сергей написал:
'Ответы на форму (1)'!$C$2:$C$15=B$1
И как я проглядел :)
март с февралем спутали
Изменено: Михаил Л - 26 мар 2020 08:36:38
 
Цитата
Михаил Л написал:
март с февралем спутали
ну это уже проблемы того кто заполняет данную форму  :)  
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх