Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Ранг с пропуском пустых ячеек и без учета повторных значений
 
Добрый день, архив тем смотрел, но решения так и не нашел.
Есть столбец значений, в том числе нулевых, надо присвоить ранг, исключив нулевые значения (порядок по возрастанию), при этом значения, которые идут за повторяющимися, не должны увеличивать свой ранг в зависимости от количества повторов. Спасибо. В примере во втором столбце указан желаемый результат.
 
Формула массива:
=ЕСЛИОШИБКА(ПОИСКПОЗ(A2;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ЕСЛИ(ПОИСКПОЗ(ЕСЛИ(A$2:A$22>0;A$2:A$22);A$2:A$22;)=СТРОКА(A$2:A$22)-1;A$2:A$22);"");СТРОКА(A$2:A$22)-1););"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Большое спасибо! Все работает, теперь бы понять логику формулы.
Изменено: roninza - 26 Мар 2020 13:18:03
 
roninza, ну а цитата здесь зачем? Вернитесь в своё сообщение и приведите его в порядок. И запомни те: кнопка цитирования не для ответа!
Страницы: 1
Читают тему (гостей: 1)
Наверх