Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выбрать ячейки с буквами, Выбрать ячейки с буквами
 
доброго времени суток.

помогите пожалуйста
есть смешанный столбец (в ячейках цифры и цифры+буквы). нужно из этого столбца в другой столбец скопировать ячейки только с цифирами+буквами.

400760001
С01318177
AB7551919
402171185
АА1292648
АВ0228219
FA0185586
заранее спасибо!
Изменено: авик - 26 Мар 2020 12:16:11
 
Цитата
авик написал:
заранее спасибо
приложите файл пример
заранее пожалуйста
Лень двигатель прогресса, доказано!!!
 
У меня есть файл со столбцом. Но в нём нет таких данных.
 
Код
Sub БуквыЦифры()
    Const col1 = 1 'Столбец 1
    Const col2 = 2 'Столбец 2
    
    Dim a As Variant
    Dim b As Variant
    Dim y As Long
    Dim u As Long
    y = Cells(Rows.Count, col1).End(xlUp).Row
    a = Range(Cells(1, col1), Cells(y, col1 + 1))
    ReDim b(1 To UBound(a, 1), 1 To 1)
    For y = 1 To UBound(a, 1)
        If Not IsNumeric(a(y, 1)) Then
            u = u + 1
            b(y, 1) = a(y, 1) 
            'b(u, 1) = a(y, 1) 
        End If
    Next
    Cells(1, col2).Resize(UBound(b, 1)) = b
End Sub
Изменено: МатросНаЗебре - 26 Мар 2020 12:35:35
 
=ЕСЛИОШИБКА(--M5;"")


400760001 400760001
С01318177
AB7551919
402171185 402171185
АА1292648
АВ0228219
FA0185586
Изменено: Михаил Лебедев - 26 Мар 2020 12:25:04
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
 
извините,

есть такой столбец
400760001
С01318177
AB7551919
402171185
АА1292648
нужно в другой получить такой

 
С01318177
AB7551919
 
АА1292648
 
Цитата
Сергей написал:
приложите файл
авик, какое из двух слов вам незнакомо  
Лень двигатель прогресса, доказано!!!
 
Код
=ЕСЛИ(ЕОШ(-A1);A1;"")
Алексей М.
 
числатекст
400760001 =ЕСЛИОШИБКА(--A2;"") =ЕСЛИ(ЕТЕКСТ(A2);A2;"")
С01318177С01318177
AB7551919AB7551919
402171185402171185
АА1292648АА1292648
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
Страницы: 1
Читают тему (гостей: 1)
Наверх