Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Проставить ниспадающие значения в списке
 
здравствуйте, уважаемые.
прошу помощи.
в файле примера в столбце В указано количество позиций. нужно в столбце А прописать ниспадающее значение от количества до единицы - как указано от 25 и вниз до 1. если кол-во =1, то проставить 1.
 
Добрый вечер
=ЕСЛИ(B2=B1;A1-1;B2)
(только в B1 удалите единицу)
Изменено: Настя_Nastya - 26 Мар 2020 19:51:37
 
работает, но не верно считает, если подряд идет одинаковое кол-во.
 
Цитата
Litvik написал:
если подряд идет одинаковое кол-во
и как должно быть?
 
вот так.
 
выполните этот макрос
Код
Sub InsNums()
  Dim r&, c&, rg As Range: r = 2
  Do While Not IsEmpty(Cells(r, 2))
    c = Cells(r, 2):  Set rg = Cells(r, 1).Resize(c, 1)
    rg.FormulaR1C1 = "=" & c & "-row()+row(R" & r & ")"
    r = r + c
  Loop
  Set rg = Cells(2, 1).Resize(r - 2, 1): rg = rg.Value
End Sub
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Труднее всего решать задачу, цель которой не ясна.

=B2-COUNTIF($C$1:C1;C2) но если и в С все одинаково, то нужно менять и пояснять что зачем и почему.
По вопросам из тем форума, личку не читаю.
 
спасибо, уважаемые!
всё получилось.
Страницы: 1
Читают тему (гостей: 1)
Наверх