Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
уникальные + неуникальные значения с условием
 
Всем доброго здоровья!
Столкнулся с проблемой, формулу для которой никак не могу сварить.
Дано: в столбце А есть уникальные и повторяющиеся значения. В столбцах B и C - цифры (или даты).
Надо: в столбце D, если значение в столбце А уникально, поставить "да". Если оно не уникально: надо поставить "да" напротив того значения, у которого разница C-B минимальная, напротив остальных надо поставить "нет".
По условию решать можно только формулой, не макросом.  
 
Формула массива
Код
=ЕСЛИ(СЧЁТЕСЛИ(A:A;A1)=1;"да";ЕСЛИ(C1-B1=МИН(ЕСЛИ(A:A=A1;C:C-B:B));"да";"нет"))

Судя из логики можно первое условие упустить и оставить только
Код
=ЕСЛИ(C1-B1=МИН(ЕСЛИ(A:A=A1;C:C-B:B));"да";"нет")
Изменено: skais675 - 27 Мар 2020 12:53:18
 
Спасибо!!
Страницы: 1
Читают тему (гостей: 1)
Наверх