Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Деление значений одной таблицы на соответствующие дате (>=) значений другой таблицы, Поиск более изящного способа вычисления, без формулы массива
 
Существует формула массива для расчета показателя опираясь на факт и план.
В одной табл. указан план на дату (последующие даты до появления новой строки рассчитываются по последней).
В другой табл. - факт на дату.

Существует формула МАССИВА
Код
=ЕСЛИОШИБКА(СУММ((C10:E10)/ВПР(A10;План;{2;3;4};ИСТИНА))*100;"") 

*100 для удобства (представления)


Хотелось бы вычислять без применения массива, но не хватает знаний.

 
как бы не массивная
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ((B8:D8)/ИНДЕКС($B$3:$D$4;ПОИСКПОЗ(A8;$A$3:$A$4;1);))*100;"")
Лень двигатель прогресса, доказано!!!
 
Шикарно, большое спасибо!
 
Boba, обращаю внимание что в формуле после поискпоз() ";" точка с запятой стоит не случайно а то в вашем варианте я её уже не вижу
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх