Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Получить из массива количество ресурсов по значению из первого столбца
 
Всем привет!
Недавно столкнулся с такой задачей
Есть Лист1 в котором есть массив. Это "производственная цепь", Столбец А - это результат производства, Стока 1 это ресурсы необходимые для его производства. Все что находится внутри на пересечении результата производства и ресурсов - это необходимое число этих ресурсов. Например, чтобы сделать 1 Лопату(А19) нам надо иметь 2 Хлопка и 2 Бамбука
Так вот задача в том, чтобы при вводе в ячейку В31 названия результата производства в ячейках ниже выводились данные о кол-ве ресурсов и названии этих ресурсов, на основании этой производственной цепи.
Уже второй день сижу, и не вижу пока куда даже копать, чтобы выводить именно название и требуемое число вместе
Заранее благодарен
Скрытый текст
Изменено: Billy - 29 Мар 2020 11:27:40
 
Здравствуйте.
Вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$1:$AA$1;СУММПРОИЗВ(НАИБОЛЬШИЙ((ИНДЕКС($B$2:$AA$27;ПОИСКПОЗ($B$31;$A$2:$A$27;);)>0)*СТОЛБЕЦ($B$1:$AA$1);СТРОКА(A1)))-1);"")
Страницы: 1
Читают тему (гостей: 1)
Наверх