Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Заменить буквы числовыми значениями и получить сумму
 
Помогите с решением! Поиск не дал результат, я пробовала из других примеров у меня не получается(

Мне нужно получить из любого слова - число - затем сложить все цифры и получить сумму.
Пример слова Задача = числовое значение  слова задача 915171= сумма 915171 = 24

Еще раз извините и спасибо!
 
Да что ж такое - я вам ссылку дал в вашей первой теме, уже все разобрано, на этом же форуме
Каждому For свой Next
 
я не вижу темы(( и там не было того что надо, там было решена часть решения.
Изменено: Степкина - 18 Май 2020 13:57:39
 
Это конечно для прикола больше ибо с алфавитом проще, но
До 30 символов, но это спасует перед Тетрагидропиранилциклопентилтетрагидропиридопиридиновые

=TEXT(SUM(IFERROR(MOD(CODE(MID(LOWER(B1);ROW(A1:A15);1))-224+LOOKUP(CODE(MID(LOWER(B1);ROW(A1:A15);1));{184;224;230};{46;0;1});9)+1;)*10^(MIN(15;LEN(B1))-ROW(A1:A15)));"0;;;")&TEXT(SUM(IFERROR(MOD(CODE(MID(LOWER(B1);ROW(A1:A15)+15;1))-224+LOOKUP(CODE(MID(LOWER(B1);ROW(A1:A15)+15;1));{184;224;230};{46;0;1});9)+1;)*10^(LEN(B1)-MIN(15;LEN(B1))-ROW(A1:A15)));"0;;;")

=SUM(IFERROR(MOD(CODE(MID(LOWER(B1);ROW(A1:A30);1))-224+LOOKUP(CODE(MID(LOWER(B1);ROW(A1:A30);1));{184;224;230};{46;0;1});9)+1;))
Изменено: БМВ - 18 Май 2020 13:39:09
По вопросам из тем форума, личку не читаю.
 
=СУММПРОИЗВ(ОСТАТ(ПОИСК(ПСТР(B1;СТРОКА(ДВССЫЛ("1:"&ДЛСТР(B1)));1);"абвгдеёжзийклмнопрстуфхцчшщъыьэюя")-1;9)+1)
Изменено: MCH - 18 Май 2020 13:34:58
 
MCH, эта формула дает сумму числа букв, спасибо!
А как получить промежуточный числовой код слова из которого мы получаем сумму?

БМВ, не понимаю в какую ячейку вставить эту формулу?
 
А зачем это всё?
 
Цитата
Степкина написал:
А как получить промежуточный числовой код слова из которого мы получаем сумму?
Зачем нужно промежуточное число, если потом все равно сумму считаем?
=СУММПРОИЗВ(10^(ДЛСТР(B1)-СТРОКА(ДВССЫЛ("1:"&ДЛСТР(B1))))*(ОСТАТ(ПОИСК(ПСТР(B1;СТРОКА(ДВССЫЛ("1:"&ДЛСТР(B1)));1);"абвгдеёжзийклмнопрстуфхцчшщъыьэюя")-1;9)+1))

Цитата
Hugo написал:
А зачем это всё?
Скорее всего нумерология, ссылку на формулы buchlotnik уже давал
Изменено: MCH - 18 Май 2020 14:00:35
 
Цитата
MCH написал: Скорее всего нумерология
Да, но не по ссылке.
Спасибо огромное!
Страницы: 1
Читают тему (гостей: 1)
Наверх