Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сравнение данных в таблицах по нескольким признакам, Нужна помощь по задаче в Excel
 
Всем доброго времени суток
Помогите решить условную задачу:
Есть две таблицы. В первой указаны даты входов определенных ПК в систему. Во второй - даты обновления ПО на определенных ПК. Нужно в первой таблице, опираясь на вторую, проставить для каждой записи признак версии ПО на момент входа в систему (старое/новое). Не могу составить подходящую формулу из-за того, что одно из условий соответствия подразумевает не точное совпадение дат, а логику >= (больше или равно указанной дате для конкретного ПК). Какая формула может решить эту проблему?
Изменено: MakeyMo - 22 Май 2020 16:30:18
 
Такие результаты устраивают?
Код
=ЕСЛИ(ВПР(C2;$K$2:$L$22;2;0)>=D2;"новое";"старое")
Изменено: Hugo - 22 Май 2020 16:41:52
 
Цитата
Hugo написал:
1=ЕСЛИ(ВПР(C2;$K$2:$L$22;2;0)>=D2;"новое";"старое")
ругается на формулу, не дает применить
 
Значит не умеете применить... Видите ведь что на скрине ничего не ругается.
Изменено: Hugo - 22 Май 2020 16:45:06
 
Цитата
Hugo написал:
Значит не умеете применить... Видите ведь что на скрине ничего не ругается.
Вот в вашем файле все работает
Может знаете, в чем может быть дело?
У меня такое уже не первый раз с чужими примерами формул...
 
Внимательно сравните формулы - увидите в чём дело.
 
Цитата
Hugo написал:
Такие  результаты устраивают?Код ? 1=ЕСЛИ(ВПР(C2;$K$2:$L$22;2;0)>=D2;"новое";"старое")
В общем основную задачу решить получилось, логику понял  :D
Огромное спасибо !
Страницы: 1
Читают тему (гостей: 1)
Наверх