Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выбор диапазона суммирования в зависимости от найденного условия, диапазон суммирования в зависимости от условия
 

Добрый вечер.

Прошу помощи в составлении формулы.


[img]http://imglink.ru/show-image.php?id=7e0813e01ff82c9a401c32b2627afe14[/img]



  1. Выбирать диапазон суммирования в зависимости от Статус
  • Перечень всех статусов – в файле на вкладке «Статус»
  • Статусы разделены на 4 категории. Статусы 01-03, Статусы 04-05, Статусы 06-07, Статусы 08-10
  • В первых 3х категориях (Статусы 01-03, Статусы 04-05, Статусы 06-07) – присваиваются числовые значения

Задача:

Статус 01,02,03 -  сумма значений «Статусы 01-03» + «Статусы 04-05»+   «Статусы 06-07»

Статус 04,05 - сумма значений «Статусы 04-05»+ «Статусы 06-07»

Статус 06,07 - значение «Статусы 06-07»

Статус 08,09 - Поле оставлять пустым  

 

2. Закрашивание Ячеек в колонках  с неактивными статусами

Задача:

Статус 01,02,03 -  в колонках со статусами нет заливки

Статус 04,05 - заливка серым в колонках «Статусы 01-03»

Статус 06,07 - заливка серым в колонках «Статусы 01-03»,«Статусы 04-05»

Статус 08,09 - заливка серым в колонках «Статусы 01-03»,«Статусы 04-05»,«Статусы   06-07»

                 

 

                       

 

 

 
Изменено: info.annas - 27 май 2020 18:44:57
 
как-то так по п.1
Код
=ЕСЛИ(ВПР(--ЛЕВСИМВ(B8;2);$A$27:$B$30;2;1)=0;"";СУММ(ИНДЕКС(D8:F8;;ВПР(--ЛЕВСИМВ(B8;2);$A$27:$B$30;2;1)):F8))
Изменено: Stics - 27 май 2020 19:38:17
 
Код
=(--ЛЕВБ(B2;2)<8)*СУММ(ИНДЕКС(D2:F2;ПОИСКПОЗ(--ЛЕВБ(B2;2);{1;4;6})):F2)

Формат ячеек 0;;

Алексей М.
Страницы: 1
Читают тему (гостей: 1)
Наверх