Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Выборочное построчное суммирование по 2 и более критериям
 
Добрый день. Помогите решить проблему, для суммирования выборочных сумм, по нескольким условиям, находящихся в одной строке - разных столбцов.

Я использую формулу: СУММЕСЛИМН($D$4:$D$10;$A$4:$A$10;A18;$B$4:$B$10;$C$14)+СУММЕСЛИМН($I$4:$I$10;$A$4:$A$10;A18;$G$4:$G$10;$C$14)+…+…

Но она получается слишком грамозкой, так как 25 отделов, и должно быть 25 формул "суммеслимн" для получения нужного результата. А ко всему прочему эти отделы - добавляются или убавляются. Приходиться постоянно редактировать формулу.

Файл с примером прилагаю.  
 
Roman_MSK,  ДД.
если месяцы расположены одинаково как в двух таблицах то можно так в В18 и протянуть
Код
=СУММЕСЛИМН(D4:N4;D$3:N$3;"Доход";$B4:$L4;$C$14)

если нужно определять последнюю ячейку с фио и доходом и в какой строке месяц то вот такой веселый вариант) та же формула что выше но чуть другая в В18 и протянуть

Код
=СУММЕСЛИМН(ИНДЕКС($1:$1048576;ПОИСКПОЗ($A18;$A:$A;0);ПОИСКПОЗ("Доход";$3:$3;0)):ИНДЕКС($1:$1048576;ПОИСКПОЗ($A18;$A:$A;0);ПРОСМОТР(2;1/($3:$3="Доход");СТОЛБЕЦ($3:$3)));
ИНДЕКС($1:$1048576;3;ПОИСКПОЗ("Доход";$3:$3;0)):ИНДЕКС($3:$3;1;ПРОСМОТР(2;1/($3:$3="Доход");СТОЛБЕЦ($3:$3)));"Доход";
ИНДЕКС($1:$1048576;ПОИСКПОЗ($A18;$A:$A;0);2):ИНДЕКС($1:$1048576;ПОИСКПОЗ($A18;$A:$A;0);ПРОСМОТР(2;1/($3:$3="Доход");СТОЛБЕЦ($3:$3))-2);$C$14)
Изменено: Mershik - 30 Май 2020 15:55:36
 
Спасибо большое. Пошел разбираться  
 
Roman_MSK, в последнем будет сложно разобраться, но это та же формула что и первая просто диапазоны указаны не явно так как мы их определяем с помощью функций ИНДЕК + ПОИСКПОЗ + ПРОСМОТР
 
У меня данные - числа и ФИО, для выборки лежат в "уной таблице"; Маркеры доход сделал отдельно, так как эта "Умная таблица" не терпит одинаковых имен, ввожу формулу =СУММЕСЛИМН(D4:N4;D$3:N$3;"Доход";$B4:$L4;$C$14), и она выдает везде нули. Ввожу конечно с учетом своих координат "А:А". Есть предположение почему и как поправить? Буду признателен, если поможете ). "Умная таблица" нужна!
 
Roman_MSK, есть, но это не точно - неверно указываете диапазоны, но этого мы никогда не узнаем (без файла примера в котором вы уже ввели формулу)
Изменено: Mershik - 30 Май 2020 20:21:25
 
Теперь получилось, спасибо. Пытаюсь понять почему раннее не получалось
 
Roman_MSK, диапазоны должны быть равным  по размеру  
Страницы: 1
Читают тему (гостей: 1)
Наверх