Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Встроить в формирование выпадающеео списка индекс и поискпоз в двссыл
 
Доброе утро. Помогите с решением.
Задача: в файле есть сводный лист, на котором с помощью выпадающего списка(клиентов) подтягиваются данные с заданного листа книги,
остальные листы это клиенты с таблицами продаж по клиентам. С помощью Двссыл, я решил эту задачу, но вопрос в том что порядок в таблицах может
отличатся от сводной и я бы хотел задействовать Индекс + Поискпоз вместе с Двссыл.
Возможно ли это реализовать или есть другое решение. Файл во вложенииЛист Microsoft Excel (2).xlsx (13.38 КБ)  
 
Так сделайте все для одного листа без двссыл, а потом диапазоны замените на нее. сильно летуче будет конечно, но по иному не получить
По вопросам из тем форума, личку не читаю.
 
Там будут данные порядка 30 клиентов за несколько лет, в штуках и рублях, да и позиций будет не две
а гораздо больше, хотел разграничить по листам плюс диаграммы.
 
Цитата
Lelya7 написал:
Возможно ли это реализовать
А почему нет, если и месяцы будут плясать то столбец() тоже нужно поменять на поискпоз( ) в А2:N2
Код
=ИНДЕКС(ДВССЫЛ("'"&$A$2&"'!A1:N300");ПОИСКПОЗ($A6;ДВССЫЛ("'"&$A$2&"'!A1:A300"););СТОЛБЕЦ())
 
То что нужно, благодарю за помощь!
Страницы: 1
Читают тему (гостей: 1)
Наверх