Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Как посчитать количество Да за указанный период времени
 
Добрый день.

Просьба помочь в решении следующего вопроса.
В одном столбце есть значения Да и Нет. В другом столбце значения с датами (несколько лет).
Как сделать подсчёт значений Да за определённый период, например, за июнь 2020г?
Снимок.PNG (16.46 КБ)
 
=СУММПРОИЗВ(...)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Роман, плохое название темы. Переформулируйте и предложите новое - модераторы поменяют.
 
Цитата
Ігор Гончаренко написал:
=СУММПРОИЗВ(...)
Спасибо. Но эта формула считает общий массив данных в столбце, а не конкретный.
В столбце более 5 тыс разных значений. Мне нужно произвести подсчёт Да в одном столбце, привязанных к конкретному периоду года и вывести общую статистику по месяца. К примеру, в январе было 20 Да, в феврале 30 и т.д.
Цитата
Юрий М написал:
Роман , плохое название темы. Переформулируйте и предложите новое - модераторы поменяют.
Не совсем понял, на что лучше поменять?
 
название темы:
как посчитать количество Да за указанный период времени

ответ;
=СУММПРОИЗВ(...)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Цитата
Роман написал:
Не совсем понял, на что лучше поменять?
На то, из чего будет понятна задача.
Благодарите Игоря - уже предложил.
 
Цитата
Ігор Гончаренко написал:
=СУММПРОИЗВ(...)
Игорь, можете показать на этом примере (файл во вложении).
Любой столбец с Да и Нет, как посчитать кол-во Да к примеру за январь 2020г.
Цитата
Юрий М написал:
Благодарите Игоря - уже предложил.
Понял, спасибо!
 
Код
=СУММПРОИЗВ((A2:G5594="Да")*(H2:H5594>=J1)*(H2:H5594<=L1))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Еще вариант но с СУММЕСЛИМН(), вместо дат можно указать ячейки куда прописывать даты.
Код
=СЧЁТЕСЛИМН(A:A;"Да";H:H;">=1.01.2020";H:H;"<=31.01.2020")
 
Цитата
gling написал:
Еще вариант
не вариант только столбец А а их несколько тут только  не без летучести
=SUM(COUNTIFS(OFFSET(A1:A5594;;{0;1;2;3;4;5;6});"Да";H1:H5594;">="&  ;H1:H5594;"<="&.....    ))
но вот по скорости эта может оказаться лучше.
По вопросам из тем форума, личку не читаю.
 
Цитата
Ігор Гончаренко написал:
1=СУММПРОИЗВ((A2:G5594="Да")*(H2:H5594>=J1)*(H2:H5594<=L1))
Спасибо большое. Всё работает. Я не знал, как правильно даты указать в этой формуле, теперь всё понятно.
А можете помочь с более сложной ситуацией.
Как посчитать сумму Да, при нескольких вводных, к примеру за январь 2020 и ещё с признаком ипотека?Задание (2).xlsx (189.34 КБ)  
 
Роман,
вводите дополнительный множитель с условием
Код
=СУММПРОИЗВ((C2:C5594="Да")*(I2:I5594>=K1)*(I2:I5594<=M1)*(A2:A5594="Ипотека"))
 
Цитата
Роман написал:
Мне нужно произвести подсчёт Да в одном столбце,
БМВ, я исходил из этого. Изначально не понятно что хочет автор. То-ли в одном столбце то-ли все Да за период.
 
Цитата
gling написал:
с СУММЕСЛИМН(),....  =СЧЁТЕСЛИМН
ну тогда этот прикол отмечу :-)
По вопросам из тем форума, личку не читаю.
 
БМВ, Спасибо, а я то этот прикол и не заметил))) Они же почти одинаково пишутся, вот и оПшиПся.
 
Всем спасибо за помощь. Вопрос решён
Страницы: 1
Читают тему (гостей: 1)
Наверх