Страницы: 1
RSS
Подсчет количества определенных значений в тексте
 
Вроде, плевая задача, но за полчаса ничего не нашел.
Определяю тошнотность ключей в сео-тексте. Текст по абзацам вставил в несколько ячеек в один столбец. Нужно количество содержания ключей в тексте.
Счетесли считает количество ячеек содержащих искомое значение. То есть он игнорирует, если в ячейке слово повторяется несколько раз.
В примере - мне нужен результат 9 битлджусов, он выдает 3.
Можно текст разбить по столбцам одно слово на ячейку, но, наверное должен быть простой нахождения количества всех значений.
 
Формула массива:
=СУММ(ДЛСТР(A1:A3)-ДЛСТР(ПОДСТАВИТЬ(A1:A3;B1;"")))/ДЛСТР(B1)
И плохо Вы искали. Количество слов в ячейке
Изменено: Максим В. - 22.06.2020 14:44:57
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Максим В., действительно плохо. Спасибо!
минус, формула чувствительна к регистру
 
Sharmat, предварительно приведите все слова к единому регистру функцией ПРОПИСН или СТРОЧН
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Максим В., да, так было проще, я че-то извращнулся и создал три списка ключевых:строчные, прописные и пропнач и взял их сумму)
Страницы: 1
Наверх