Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Отбор данных по дате, объекту и товару
 
Здравствуйте.
снова к вам за помощью) Вы меня всегда выручаете!

На этот раз, прошу помочь составить формулу в которой будут учтены условия, чтобы на выходе получить результат который выделен в зеленой колонке.  Наверно это будет формула =Если()
ДатаОбъект№ строкиТовар Кол-во повт.ДОФОРасхВводРезультатФОРМУЛА
23.июн9896имбирь3181802ввод > 0ввод>0
23.июн9898молоко12202-ввод>0
23.июн98912хлеб14404-ввод>0
23.июн98925имбирь3181804ввод > 0,   добавление значения
23.июн98926имбирь31818012ввод > 0.   Расхождений нетввод>0.   Расхождений нет
24.июн3484томаты41211-18ввод > 0ввод>0
24.июн34812томаты41211-11ввод > 0,   добавление значения
24.июн34813сахар11111011-ввод>0
24.июн34814томаты41211-11ввод > 0,   добавление значения
24.июн34819томаты41211-11ввод > 0. Принято   расхождениеввод>0. Принято   расхождение
Необходимо учесть в условии формулы отбор по дате, отбор по объекту и отбор по товару. В комментарии пометила очередность ввода, которая может быть не по порядку. В процессе инвентаризации объект вводит количество товара по мере его нахождения. Результат суммируется в колонке ФО и выявляются расхождения. таким образом мне необходимо отслеживать процесс инвентаризации каждого действия в системе.
Например, можно по № строки товара определить его первичный ввод (6<25), значит в строке 25 значение будет добавлено. а строка 26 это последний ввод количества этого товара, в этом магазине, в этот день . Как раз с этим у меня возникли затруднения(( Может вы подскажите другие варианты решения.
 
Цитата
AnutaHappy написал:
Наверно это будет формула =Если()
Код
=ЕСЛИ(СЧЁТЕСЛИМН($A$2:$A$11;A2;$B$2:$B$11;B2;$D$2:$D$11;D2)=1;
                "-";
                "ввод>0"&ЕСЛИ(СЧЁТЕСЛИМН($A$2:$A2;A2;$B$2:$B2;B2;$D$2:$D2;D2)=1;
                                                   "";
                                                   ЕСЛИ(СЧЁТЕСЛИМН($A$2:$A$11;A2;$B$2:$B$11;B2;$D$2:$D$11;D2)>СЧЁТЕСЛИМН($A$2:$A2;A2;$B$2:$B2;B2;$D$2:$D2;D2);
                                                                ", добавление значения";
                                                                ЕСЛИ(H2=0;
                                                                             ". Расхождений нет";
                                                                             ". Принято расхождение"))))
 
Михаил Л, Очень-очень вас благодарю!!!! то что надо
Страницы: 1
Читают тему (гостей: 1)
Наверх