Страницы: 1
RSS
Подбор подходящего значения, номер паллеты, максимально подходящей для доукомплектации фуры
 
Всем добрый день.
Есть задача Комплектовщик распределяет паллеты по фурам грузоподъемностью до 20 тонн.
Для ускорения работы комплектовщика необходимо реализовать алгоритм выбора паллеты для доукомплектации, максимально загружающей, но не перегружающей фуру.
При вводе веса уже загруженных паллет в ячейку G15, в соседней ячейке H15 должен отобразиться номер паллеты, максимально подходящей для доукомплектации фуры. Файлик прилагаю.

Всю голову сломала(((
 
Я нашла решение, может быть, кому-то пригодится
Код
={ИНДЕКС(A6:A105;МИН(ЕСЛИ(D6:D105=МАКС(ЕСЛИ(D6:D105>=20000-G15;"";D6:D105));
           СТРОКА(D6:D105)-СТРОКА(D5);"")))}
 
а почему П-22, а не П-4?
Код
=ИНДЕКС(A6:A105;ПОИСКПОЗ(МАКС(ЕСЛИ(D6:D105<=20000-G15;D6:D105;""));D6:D105;))
Соблюдение правил форума не освобождает от модераторского произвола
 
Формула без массивного ввода
Код
=INDEX(A6:A105;MATCH(MAX(INDEX(D6:D105*(D6:D105<=(20000-G15));0));D6:D105;0))
Изменено: jakim - 14.07.2020 21:22:04
 
до кучи динамический вариант
Код
=ИНДЕКС(СОРТ(ФИЛЬТР(A6:D105;D6:D105<=20000-G15);4;-1);1;1)
Соблюдение правил форума не освобождает от модераторского произвола
 
Спасибо большое за ответы! Все получилось!
Изменено: tapotr86 - 15.07.2020 21:17:21
Страницы: 1
Читают тему (гостей: 1)
Наверх