Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Аналитическая справка по закупке, Подсчет средней цены с учетом соответствия/не соответствия товара техническим требованиям
 
Здравствуйте.
Прошу помощи, длительные поиски в интернетах ни к чему не привели.
Исходные (для понимания задачи):
Проводится опрос рынка, получаем предложения поставщиков на товары. Предложения оцениваются специально обученными людьми и по каждой позиции выносится вердикт - соответствует предложение заявленным изначально требованиям или не соответствует. Вся информация вносится в таблицу (указал только ключевые столбцы):
Наименование товара Предложение поставщика 1 (цена)Соответствие Предложение поставщика 2 (цена) Соответствие Предложение поставщика 3 (цена) Соответствие Предложение поставщика 4  (цена)Соответствие   Средняя цена
Товар 1 100Соответствует 110 Соответствует 90 Соответствует
Товар 2 200 Не соответствует 190 Соответствует 220 Не соответствует
Товар 3 300 Не соответствует 330 Не соответствует 290 Не соответствует 310 Не соответствует
Количество поставщиков может быть разным.

Задача:
В правой части таблицы нужно посчитать среднюю цену по каждому товару с учетом информации о соответствии/не соответствии предложений по технике.


Буду благодарен за любые советы )
Спасибо
Изменено: Юрий - 15 Июл 2020 12:09:35
 
сделайте краткий пример и приложите к сообщению
 
Цитата
Юрий написал:
о соответствии/не соответствии
Код
=ЕСЛИОШИБКА(СРЗНАЧ(ЕСЛИ(C2:I2="Соответствует";B2:H2));0)&"/"&ЕСЛИОШИБКА(СРЗНАЧ(ЕСЛИ(C2:I2="Не соответствует";B2:H2));0)
 
Цитата
Vik_tor написал:
сделайте краткий пример и приложите к сообщению
Сделал файл для примера, приложил.
 
Для примера массивная
Код
=ЕСЛИОШИБКА(СРЗНАЧ(ЕСЛИ(E3:N3="Соответствует";D3:M3));0)&"/"&ЕСЛИОШИБКА(СРЗНАЧ(ЕСЛИ(E3:N3="Не соответствует";D3:M3));0)
 
Юрий, количество поставщиков всегда равно 4 или меняется?
 
Количество поставщиков может быть разным.
 
1. Вместо лишних столбцов добавьте один "Поставщик"
Цитата
Юрий написал:
среднюю цену по каждому товару с учетом информации о соответствии
а как ее учитывать?
Изменено: Михаил Лебедев - 15 Июл 2020 13:15:31 (добавил файл)
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
 
Если правильно понял задачу:
=ЕСЛИОШИБКА(СРЗНАЧЕСЛИ(E3:N3;"Соответствует";D3:M3);"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Максим В., тоже работает. Спасибо!

Цитата
Михаил Л написал: Для примера массивная
Dот это вот, что через слеш добавлялось убрал и как массивная сработала вот в таком варианте. Уже что-то, спасибо большое!
Код
{=ЕСЛИОШИБКА(СРЗНАЧ(ЕСЛИ(AB11:EC11="Соответствует";W11:DX11));0)}

Цитата
Михаил Лебедев написал: а как ее учитывать?
Если предлагаемый поставщиком товар соответствует требованиям - цена учитывается в формуле расчета средней цены, если не соответствует, то не учитывается.
 
Цитата
Юрий написал:
это вот, что через слеш добавлялось убрал
А убрали зачем? До слеша соответствия, после слеша несоответствия.
Вы же просили:
Цитата
Юрий написал:
Подсчет средней цены с учетом соответствия/не соответствия
 
Цитата
Михаил Л написал:
А убрали зачем? До слеша соответствия, после слеша несоответствия.
Видимо не до конца сформулировал )
По сути, предложения, которые не соответствуют, вообще нам не нужны и не должны учитываться.
Т.е. по строке берем все цены из предложений, которые соответствуют, и ищем среднюю (ну или минимум, это уже другая задача, но принцип тот же).

А вот ещё, кстати, вопрос - если ищем минимальную цену по строке, можно ли вытянуть наименование поставщика из заголовка? Т.е., условно, в какой-то строке три поставщика соответствуют, и в два столбца справа вытягивается минимальная цена (с этим понятно) и наименование поставщика.
 
Цитата
Юрий написал:
вопрос - если ищем минимальную цену по строке, можно ли вытянуть наименование поставщика из заголовка?
Вопрос конечно не в тему, хотя что из за такой мелочи темы плодить
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$1:N$1;ПОИСКПОЗ(МИН(ЕСЛИ(E3:N3="Соответствует";D3:M3));D3:M3;));"")
 
Цитата
Юрий написал:
можно ли вытянуть наименование поставщика
Всё сложное - не нужно. Всё нужное - просто /М. Т. Калашников/
 
Спасибо всем большое! Очень помогли!
Вы дали мне удочку, дальше пойду сам ловить :)

ПС: Прикрепил итоговый файл с формулами, может пригодится кому ещё.
Изменено: Юрий - 16 Июл 2020 15:37:37
Страницы: 1
Читают тему (гостей: 1)
Наверх